Win3x.Org

Windows & DOS Community

Microsoft Windows 1.x [en] [fr]

Répondre
Nom d’utilisateur :
Sujet :
19 moins 3 = ? (tapez la réponse en toutes lettres) :
Cette question vous permet de vous prémunir contre les soumissions automatisées et intensives effectuées par des robots malveillants.
Corps du message :
Émoticônes
:D :) :wave: :clap: ;) :( :o :shock: :? 8-) :lol: :uh: :x :P :oops: :cry: :angel: :evil: :twisted: :roll: :o_O: :!: :?: :idea: :arrow: :shh: :approve: :disapprove: :| :mh: :mrgreen: :mrblue: :mrred:
 
Options :
Le BBCode est activé
La balise [img] est activée
La balise [flash] est désactivée
La balise [url] est activée
Les émoticônes sont activées
Désactiver les BBCodes
Désactiver les émoticônes
Ne pas analyser automatiquement la syntaxe des liens
   

Relecture du sujet - Microsoft Windows 1.x [en] [fr]
Auteur Message
Joet BERNARD
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Salut !!
Je suis en train de faire mes captures pour mon site et j'ai remarqué en installant Windows PE que les disquettes ont des noms en Disk0# alors que ça devrait être "Setup" "Build" "Utilities" et "Applications". En plus lors de la demande de la 3ème disquette (celle nommée "Applications") je dois mettre la disquette Disk04, la dsiquette Disk03 étant la disquette "Utilities" venant juste après. Voici du coup une nouvelle archive qui corrige ce petit défaut :
http://www.dropbox.com/s/y695gfpfwaktr ... n.zip?dl=0
Le contenu des disquettes n'a pas été modifié, seulement le nom visible de celles-ci (les labels n'ont pas non plus étés modifiés)

Pour une raison que j’ignore, je ne trouve plus le fichier win3x.txt nulle part, il a été retiré de tous les fichiers ZIP ???
Publié : 15 oct. 2019 12:58
Nintenloup
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
remax17 a écrit : *  24 mai 2019 11:10
C'est possible mais c’était pas l'habitude à l’époque. Quand on écrivait 640K nécessaire, c'était la RAM totale (heureusement ! :D)
Généralement, il est précisé si ça doit estre ce qu'il reste de libre et non pas de ram totale.
Publié : 30 mai 2019 06:07
Deksor
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Joet BERNARD a écrit : *  24 mai 2019 13:04
Je reprécise que la carte émulée est un EGA. Mais après vérification je crois que le problème vient peut être de PCem

Édit :
Win1.03 avec PCem/86box : 640x349/640x350
Win1Beta avec PCem/86box : 640x398/640x400
Le problème vient donc de PCem: Affaire conclue !!!
Oui sauf que si l'os vise une carte CGA, il ne pourra pas faire de mode aussi élevé. C'est comme demander à un windows 32 bits d'accéder à plus de 4Go de RAM. Il peut techniquement le faire avec les cpu pae, mais il ne peut pas le faire tout seul.

@big monstre la nuance est importante en effet, mais on peut très bien remplir sa RAM avec une demi tonne de TSR et ne pas pouvoir exécuter le programme que l'on veut à cause de cela même si la boîte dit "512KB System ram" par exemple.

La RAM minimale nécessaire indiquée pour les programmes ça reste toujours une estimation un peu grossière quand ce n'est pas précisé exactement, ou une limite arbitraire (98 fonct bien si on le force à démarrer avec 12mo de RAM par exemple)
Publié : 24 mai 2019 16:34
Big Monstro
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Microsoft Windows 1.01 est prévu pour pouvoir fonctionner avec 256 Ko de RAM (du moins avec DOS 2.0 ou 3.0, les versions de l'époque).

Je ne sais pas si ce chiffre se rapporte à la quantité de mémoire totale ou disponible mais, en ce temps-là, le moindre Ko de libre avait de l'importance et on ne parlait pas de fichier d'échange sur le disque dur (cet unité de stockage est même facultatif jusqu'à Windows 2.03 inclus !). Je parie néanmoins que Windows 1.01, sorti en 1985, devait fonctionner sur le haut de gamme de l'année précédente, c'est-à-dire l'IBM PC/AT, équipé d'un processeur 80286 et de tout juste 256 Ko de RAM par défaut, par conséquent moins de 256 Ko de libre (MS-DOS doit être chargé). Comme son lointain successeur, Windows Vista, Windows 1.01 est aussi sorti en retard.

Il me semble que les révisions suivantes (Windows 1.02, Windows 1.03 ou Windows 1.04) réclament un peu plus, il faut donc prévoir plutôt 320 Ko de RAM, et je sais que son successeur direct, Windows 2.0x, a été prévu pour fonctionner avec rien de moins que 512 Ko et DOS 3.0, mais, là encore, je ne sais pas si "512" se rapporte à la quantité totale ou disponible. A l'époque, je le répète, la nuance avait de l'importance (vu qu'en plus, Windows fonctionnait par dessus un autre produit vendu séparément, le DOS, qui avait ses propres besoins, variables selon la version).
Publié : 24 mai 2019 15:02
Joet BERNARD
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Deksor a écrit : *  24 mai 2019 12:41
Euh attends déjà 640*400 n'est juste pas possible en CGA "normal".
Je reprécise que la carte émulée est un EGA. Mais après vérification je crois que le problème vient peut être de PCem

Édit :
Win1.03 avec PCem/86box : 640x349/640x350
Win1Beta avec PCem/86box : 640x398/640x400
Le problème vient donc de PCem: Affaire conclue !!!
Publié : 24 mai 2019 13:04
Deksor
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Euh attends déjà 640*400 n'est juste pas possible en CGA "normal".

En 1bit par pixel ça demande 32Ko de mémoire, le CGA n'en propose que 16. Donc c'est 640*200 maxi. 640*398 n'existe pas en CGA à la connaissance (ou alors c'est un mode bidouillé, mais je ne vois quand même pas comment ça a la moindre chance de fonctionner étant donné le problème précédemment cité).

@remax17 pour les applications DOS de cette époque là j'ai vu les deux ...

@babass c'est pas parce que 3.0 est plus évolué qu'il demande forcément plus de RAM ^^ Il est sûrement plus efficace tout simplement.
Publié : 24 mai 2019 12:41
Joet BERNARD
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Je vous assure que ces ces résolutions la jais refait trois fois les captures !!!

Eh j'ai eu un avertissement comme quoi j'ai pas assez de mémoire avec Win1 DR5 Alpha Beta et 1.03 (seuls testés à présent)
Je ne parle pas de Win3 !!!
Publié : 24 mai 2019 12:19
babass
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Ça devrait pas plutôt être 640*400 et 640*350 ? Tu te fait arnaquer de 1 ou 2 rangées de pixels là :lol: :lol:
Joet BERNARD a écrit : *  24 mai 2019 06:47
babass a écrit : *  24 mai 2019 00:23
A mon avis il y a un problème dans la config de ton DOS. Car même Windows 3.0 arrive quand même à démarrer avec 512Ko de mémoire il me semble.
Je pense pas...
Bah je pense que si, je viens de le faire, Windows 3.0 avec 512Ko de RAM avec DOS 5.0.
Publié : 24 mai 2019 12:16
Joet BERNARD
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Deksor a écrit : *  24 mai 2019 08:17
Bah c'est normal l'EGA est rétrocompatible avec le cga, idem avec le cga et l'ega (et donc aussi le cga)
Et comment tu explique la résolution 640x398 (en graphique sous Win1dr5 et Alpha) ou 640x349 (en mode texte sous PC-DOS 3.0) :P
Publié : 24 mai 2019 12:08
remax17
Sujet du message : Re: Microsoft Windows 1.x [en] [fr] Citer
Deksor a écrit : *  23 mai 2019 23:57
À mon avis dans le minimum requis, 512Ko de RAM ne veut pas dire que l'ordi doit avoir cette quantité de ram installée mais plutôt cette quantité de ram dispo !

C'est possible mais c'etait pas l'habtude à l'epoque. Quand on écrivait 640K nécessaire, c'était la RAM totale (heureusement ! :D)
Publié : 24 mai 2019 11:10