Win3x.Org

Windows & DOS Community

[Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris

Règles du forum

Ce forum sert à contribuer au site ou faire une demande de contribution. Pour proposer un programme, suivez simplement le guide en trois étapes !
Les présentations des différents programmes ne sont pas figées : si vous pensez pouvoir les améliorer, n'hésitez pas à proposer votre version !

Répondre   Page 2 sur 2  [ 15 messages ]
Aller sur la page « 1 2
Auteur Message
Joet BERNARD
Sujet du message : Re: [Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris
Publié : 17 oct. 2020 15:54
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 1323
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
Message original de 10/10 : J'ai commencé a rassemblé des informations et des archives pour compléter cette proposition, auxquelles je rajoute quelques captures.
Je n'ai pas fini le travail je m'y consacrerai avec plus d'investissement lundi.
L'ensemble de ce qui a été fait est logé dans ce dossier :
https://mega.nz/folder/UYhzBIiS#JWj0tDwM65yM_FSvc-C1KQ
Il n'inclut pour le moment pas la version proposée de base mais ce dossier va évoluer jusqu'à rassembler l'ensemble des trouvailles.

Petite note : les systèmes utilisés sont :
- Windows 95 avec !Plus avec OOo 1.1.2 (version française) et OOo 1.1.5 (version anglaise) (pas encore présent dans ce dossier) ;
- Windows NT 4.0 avec SP6a, patches post SP6 et IE 6 SP1 avec OOo 2.1.0 (je recommencerai avec une version moins complète, mais OOo 2.1.0 n'est pas installable avec notre ISO de NT4 Workstation SP1 sans mise à jour) ;
- Windows 98 SE simple avec OOo 2.4.2 (version française) et OOo 2.4.3 (version anglaise).

Ne sont présentent pour l'instant que les versions 2.2.0 et plus (donc uniquement compatible avec Windows 98), toutes dans des archives ZIP Deflate.

Je vais étoffer le dossier dès que je le pourrai.

Les captures ont étés prisent avec PCem (Windows 95 et 98) ou VMware (NT 4.0) et sont en PNG (la qualité est-elle bonne ?).

Bien le bon soir a tous,
Très cordialement, Signé JARB !

Édit plus tard :
Je viens de trouver les requis de la version 1.0 de OOo que l'on trouve en farfouillant un peu les messages du forum et je peux dire que officiellement OOo ne tourne qu'à partir du SP6 de NT4.
Voici les requis (trouvé dans les fichiers d'installation) :
Citation :
- Microsoft Windows 95, 98, ME, NT (Service Pack 6 or higher), 2000 or XP (Please note: Windows 95 requires a DCOM95 update. For further information, visit http://www.microsoft.com/com/dcom/dcom95/dcom1_3.asp)
- Pentium compatible PC
- 64 MB RAM
- 250 MB available hard disk space
- 800x600 DPI resolution or higher, at least 256 colors
Edit Lun 12/Oct :
J'ai barré les informations obsolètes.
Les captures de Windows 95 sont désormais disponibles !
Les version 1.0 jusqu'à 2.1.0 sont aussi disponibles !
Je rajoute que pour pouvoir utiliser OOo sous Windows 95, il vous faut le fichier MSVCRT.DLL en plus du DCOM95.
Si Internet Explorer 4 accompagne nativement votre système d’exploitation, cette DLL doit déjà être localisée dans le répertoire System. En clair, la seule installation du DCOM suffit à rendre Windows 95 C OSR2.5 compatible avec OOo.
En dehors de cette édition et si vous ne souhaitez pas installer Internet Explorer sur votre Windows 95, alors vous pouvez reprendre la DLL en suivant ce lien :
msvcrt.dll 6.0.8397.0 issu de Visual Studio service pack 3 (Internet Archive)
De plus, pour les version les plus anciennes, le DCOM n'est pas obligatoire, mais OOo vous averti qui peux être instable sans.
Pour terminer, l'archive de Mises à jour françaises de Windows 95 ne répertorie pas le fichier DCOM95.EXE. Il est cependant disponible dans l'archive de Internet Explorer 5.5 SP1.

Je vais maintenant me pencher un peu plus sur Windows NT 4.0.

Merci pour votre intérêt marqué, Signé JARB !

Edit : Mer 14/10 : Petit retour sur le cas de Windows NT 4.0 :
Les versions 1.0.X et 1.1.0 de OOo peuvent s'installer de manière native sur Windows NT 4.0 SP1 (pas moyen de tester sans SP)
Les versions 1.1.2 et 1.1.5 de OOo requiert au minimum le SP4
Les version 2.x nécessitent le SP6a.

Édit Sam 17/10 : Y a-t-il quelqu'un d'intéressé ???

_________________

Accueil de mon Index de sites
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version (5) "Beta")
Ma collection au complet


Haut
Profil Citer
remax17
Sujet du message : Re: [Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris
Publié : 17 oct. 2020 17:39
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 1092
Inscription : 22 sept. 2010 15:03
PC Rétro : PIII 500mhz -384Mb RAM - Voodoo 2 en SLI
 

_________________

Mon OneDrive


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: [Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris
Publié : 20 oct. 2020 17:51
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 1323
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
Message original du 17 Octobre :
Et ben tu sais quoi remax ? C'est exactement ici que j'ai pioché mes fichiers !

Édit du 20 Octobre :
J'ai fait tout ce qu'il était possible de faire. C'est aux Modo/Admin de se charger du reste

_________________

Accueil de mon Index de sites
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version (5) "Beta")
Ma collection au complet


Haut
Profil Citer
Big Monstro
Sujet du message : Re: [Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris
Publié : 24 oct. 2020 17:31
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3494
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 3.11
 
Je te remercie Joet BERNARD pour tous ces détails !
Joet BERNARD a écrit : *  17 oct. 2020 15:54
De plus, pour les version les plus anciennes, le DCOM n'est pas obligatoire, mais OOo vous averti qui peux être instable sans.
En tout cas, pour la version 1.1.2 d'OpenOffice.org, DCOM95 est vraiment un prérequis. Sur un système Windows 95 RTM fraîchement installé (sans aucune MAJ, et sans IE), le processus d'installation refuse purement et simplement de se lancer

OLEAUT32.gif

Après avoir appliqué DCOM95 et redémarré la machine, j'ai pu installer OOo 1.1.2. J'ai toutefois eu droit à ce message d'erreur en cours de route.

ucpftp1.gif

Est-ce parce que je n'ai pas ajouté le fichier MSVCRT.DLL sur mon système ? Ou parce que j'ai choisi une installation personnalisée (pour tout sélectionner) ?

Finalement, cela semble fonctionner, du moins durant les quelques minutes que j'ai utilisé la suite bureautique.

Il n'y a ni JAVA, ni IE, ni le fichier MSVCRT.DLL sur le système.

ooo112_win95.gif

As-tu été confronté à l'erreur d'inscription du composant ucpftp1.dll lors de l'installation d'OpenOffice.org 1.1.2 sur ton Windows 95 ?
Joet BERNARD a écrit : *  17 oct. 2020 15:54
Les versions 1.1.2 et 1.1.5 de OOo requiert au minimum le SP4
Le fichier readme.txt d'OOo 1.1.2 mentionne pourtant le Service Pack 6. Est-ce que cela fonctionne malgré tout avec Windows NT 4.0 SP4 ?


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: [Proposition] OpenOffice.org 1.1.2 [fr] Windows, Linux, Linux PPC, Mac OS X, Solaris
Publié : 24 oct. 2020 18:51
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 1323
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
Big Monstro a écrit : *  24 oct. 2020 17:31
...
As-tu été confronté à l'erreur d'inscription du composant ucpftp1.dll lors de l'installation d'OpenOffice.org 1.1.2 sur ton Windows 95 ?
Joet BERNARD a écrit : *  17 oct. 2020 15:54
Les versions 1.1.2 et 1.1.5 de OOo requiert au minimum le SP4
Le fichier readme.txt d'OOo 1.1.2 mentionne pourtant le Service Pack 6. Est-ce que cela fonctionne malgré tout avec Windows NT 4.0 SP4 ?
Oui j'avais oublié de le préciser, mais ça n'affecte pas du tout l'utilisation de l'application (je suis aussi passé par l'installation personnalisée). J'ai pu manipuler les polices, en rajouter de nouvelles, les redimensionner... Et aussi enregistrer un fichier sans que OOo me fasse faux bond.

Le fichier MSVCRT.DLL m'étais demandé avec les versions 1.0.x quand DCOM95 n'était pas installé.

En rapport, quand je disais que DCOM95 n'est pas obligatoire c'était précisément sur les versions 1.0.x de OOo que cela nous concerne. Il est tout a fait possible d'installer et utiliser les OOo 1.0.x de manière native sur 95 C fraîchement installé. Autrement, il faut rajouter les fameux MSVCRT.DLL, car n'est présent qu'à partir de IE4, composant natif de 95C comme tu l'avais expliqué.

Pour NT4, oui j'ai lu le fichier ReadMe.txt et j'ai même recopié dans mon message. Mais ma curiosité m'a poussé a tester avec les services pack antérieur, et mes conclusions sont bien celles citées :
Joet BERNARD a écrit : *  17 oct. 2020 15:54
Les versions 1.0.X et 1.1.0 de OOo peuvent s'installer de manière native sur Windows NT 4.0 SP1 (pas moyen de tester sans SP)
Les versions 1.1.2 et 1.1.5 de OOo requiert au minimum le SP4
Les version 2.x nécessitent le SP6a.

_________________

Accueil de mon Index de sites
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version (5) "Beta")
Ma collection au complet


Haut
Profil
Afficher : Trier par : Ordre :
Répondre   Page 2 sur 2  [ 15 messages ]
Revenir à « Contributions » | Aller sur la page « 1 2
Aller :