Win3x.Org

Windows & DOS Community

faire fonctionner des logiciel recent sous xp solutions

Répondre   Page 1 sur 2  [ 11 messages ]
Aller sur la page 1 2 »
Auteur Message
pm67190
Sujet du message : faire fonctionner des logiciel recent sous xp solutions
Publié : 21 mars 2020 00:15
Membre inscrit
Hors-ligne
 
Messages : 71
Inscription : 01 mars 2020 19:04
 
Bonjour à tous,

pour ceux qui voudrais faire fonctionner des logiciel recent sous xp avec l'erreur application win32 non valide

cet astuce peut éventuellement fonctionner

en gros il vous faut CFF explorer

votre logiciel incompatible xp "si possible compatible vista ou windows "

ouvrir l’exécutable ou les dll se rendre dans la rubrique optional header et modifier

la section MajorSubsystemVersion et MinorSubsystemVersion ainsi que MajorOperatingSystemVersion et

MinorOperatingSystemVersion
de 6.1 en 5.1

pour infos (5.1 > XP - 5.2 XP ou serveur 2003 64bits - 6.0 vista , 6.1 windows 7 , 6.2 windows 8 , 6.3 win 8.1 )

la rubrique dependency walker permet de lister les dll cela peut être utile

exemple ci-dessous de fraps

[ img ]


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 26 mars 2020 17:01
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 953
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
Est-ce qu'au moins il fonctionne dans un jeu FRAPS ? :)

_________________

Accueil de mon Index Micso
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version "Alpha")
Ma collection au complet


Haut
Profil Citer
Fireboy3000
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 26 mars 2020 21:41
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 737
Inscription : 12 oct. 2016 14:13
PC Rétro : PC 1998 AMD-K6 333MHz + ATI rage II
 
Bonsoir,
est-ce que ça permettrait d'utiliser des versions récentes de navigateurs Internet?

_________________

Le Soleil a rendez-vous avec la Lune mais la Lune n'est pas là et le Soleil l'attend.
Les lentilles sont des petits pois trop cuits. :o


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 26 mars 2020 21:55
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 953
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
En tout cas il a l'air d'être aux .EXE ce que Microsoft Orca est pour les .MSI
Je vais l'essayer

Un combo Orca plus CFF Explorer et nous voilà repartis avec XP :D
En plus si CFF Explorer fonctionne sous 2000 on pourra aussi le ressortir :lol:

_________________

Accueil de mon Index Micso
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version "Alpha")
Ma collection au complet


Haut
Profil Citer
Fireboy3000
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 26 mars 2020 22:53
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 737
Inscription : 12 oct. 2016 14:13
PC Rétro : PC 1998 AMD-K6 333MHz + ATI rage II
 
J'ai essayé mais il n'y a pas de 6.1 à changer en 5.1 dans CFF explorer :
appli.png
J'ai peut-être raté quelque chose?

_________________

Le Soleil a rendez-vous avec la Lune mais la Lune n'est pas là et le Soleil l'attend.
Les lentilles sont des petits pois trop cuits. :o


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 26 mars 2020 23:24
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 953
Inscription : 19 mars 2016 20:33
PC Rétro : Pentium 4 1,5 GHz, 512 Mo de RAM, FX 5200
 
Même idée...mais avec 2000 :D
J'ai réussi a l'installer sur 2000. Il faut le fichier GDIPLUS.DLL extrait de MS Office 2003 pour que ça fonctionne.
Pour ma part, j'essaie de modifier Firefox 13, FF12 étant la dernière version compatible avec 2000.
Pour être certain de bien modifier le fichier, j'ai "Extra l'exe de bas vers un dossier mais je tombe sur le même résultat que toi...

Édit : ya erreur sur la marchandise, FRAPS prend en charge Windows XP :evil: -> Vérifiez https://www.fraps.com/download.php
Et puis il utilise Windows XP Pro x64 qui pour rappel est basé sur Serveur 2003, ça se voit dans winver ; la version du noyau NT est 5.2 :evil: :evil: :evil:

Édit 2 : par contre FRAPS "s'installe" sous 2000 mais ne démarre pas (application Win32 non valide), et avec CFF Explorer j'ai pu changer le message d'erreur en un message d'avertissement de piratage

_________________

Accueil de mon Index Micso
WINJOY hors-ligne (actuellement en version (4) "Alpha")
Accueil en ligne de WINJOY (actuellement en version "Alpha")
Ma collection au complet


Haut
Profil Citer
pm67190
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 27 mars 2020 00:23
Membre inscrit
Hors-ligne
 
Messages : 71
Inscription : 01 mars 2020 19:04
 
[ img ]

il n'y a pas d'erreur sur la section


Haut
Profil Citer
pm67190
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 27 mars 2020 00:27
Membre inscrit
Hors-ligne
 
Messages : 71
Inscription : 01 mars 2020 19:04
 
Fireboy3000 a écrit : *  26 mars 2020 22:53
J'ai essayé mais il n'y a pas de 6.1 à changer en 5.1 dans CFF explorer :
appli.png
J'ai peut-être raté quelque chose?
oui sur le poste principal la valeur n'est pas forcement 6.1 , la valeur peut être :

4.0 = nt4 , 5.0 = windows 2000 , 5.1 xp ou 2003 32bits

5.2 xp 64 ou srv 2003 64 , 6.0 vista , 6.1 windows 7, 6.2 windows 8 , 6.3 windows 8.1 , AO pour windows 10

exemple calculatrice xp il suffit de modifier 5.1 en 5.0

[ img ]


Haut
Profil Citer
Fireboy3000
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 27 mars 2020 13:56
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 737
Inscription : 12 oct. 2016 14:13
PC Rétro : PC 1998 AMD-K6 333MHz + ATI rage II
 
Je n'ai malheureusement pas réussi à faire fonctionner de navigateur modernes sur Windows Xp (Opera, Firefox, Chrome, Chromium), j'ai réussi à supprimé une erreur Windows 32 sur Firefox mais j'ai une autre erreur à la place (et ça n'a pas l'air solvable, je réessaierai plus tard).

_________________

Le Soleil a rendez-vous avec la Lune mais la Lune n'est pas là et le Soleil l'attend.
Les lentilles sont des petits pois trop cuits. :o


Haut
Profil Citer
Big Monstro
Sujet du message : Re: faire fonctionner des logiciel recent sous xp solutions
Publié : 28 mars 2020 12:46
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3389
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 95
 
Ce que propose pm67190 permet juste de contourner la vérification de la version du système d'exploitation.

Si le programme est réellement incompatible avec Windows XP pour une raison x ou y, il continuera à l'être.


Haut
Profil Citer
Afficher : Trier par : Ordre :
Répondre   Page 1 sur 2  [ 11 messages ]
Revenir à « Informatique moderne » | Aller sur la page 1 2 »
Aller :