Win3x.Org

Windows & DOS Community

Problème IBM Aptiva 2144-768

Règles du forum

Pour tout sujet impliquant un système d'exploitation daté de 2000 à nos jours, merci de le publier dans la section intitulée « Informatique moderne ».

Répondre   Page 1 sur 1  [ 16 messages ]
Auteur Message
Iskeryn
Sujet du message : Problème IBM Aptiva 2144-768
Publié : 10 oct. 2018 03:57
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Bonjour,

Je me suis mis en tête il y a quelques jours de remettre en état le PC de mon enfance, un IBM Aptiva 2144-768 équipé d'un 486DX2. Seulement je fais face à plusieurs problèmes que je rencontre depuis que je possède ce PC, notamment un qui est très handicapant pour une machine de cette époque. En effet au démarrage de l'ordinateur, à l'apparition du logo IBM donc à l'initialisation du BIOS, j'obtiens 3 erreurs. Deux erreurs 1101 ainsi que l'erreur 106. Les deux premières erreurs (1101) sont, d'après la documentation de IBM, des erreurs liées aux ports série et l'erreur 106, elle, semble correspondre à un problème sur la carte mère. En fouillant un peu dans des documents IBM trouvés sur Internet, il semblerait que l'erreur 106 corresponde plus exactement à "System board error - converting logic test".

Il m'est aussi complètement impossible de faire fonctionner un lecteur de disquette sur ce PC, quoi que je fasse, l'ordinateur ne le détectera pas (même pas dans le BIOS). J'ai bien entendu testé un autre lecteur disquette sur mon Aptiva mais le résultat est le même, le lecteur n'est pas détecté. J'ai aussi testé le lecteur de disquette du IBM sur d'autres machines de la même époque et il fonctionne. J'ai également fait la même chose pour la nappe du lecteur, je l'ai échangée pour celle d'un autre PC mais le résultat est le même. J'ai aussi essayé d'inverser la nappe (connecter le côté qui était branché au lecteur et le raccorder à la carte mère et inversement) mais c'est exactement pareil.
J'ai pendant un temps pensé que le problème était lié à l'alimentation, mais en faisant des mesures je me suis aperçu que les tensions étaient bonnes pour le connecteur d'alimentation du lecteur disquette (12V d'un côté et 5V de l'autre). J'ai me suis aussi assuré qu'il n'y avait aucun faux contact, mais en vain.

Pour tenter de résoudre ces problèmes j'ai nettoyé l'intégralité de la carte mère à l'alcool à 90°, mais cela n'a rien changé du tout.
Pour m'assurer qu'il n'y avait pas d'autres problèmes avec ce PC, je me suis débrouillé pour installer MS-DOS 6.22 ainsi que Windows 3.11 (car le disque dur avait été formaté il y a quelques années). Tout s'est bien passé à ce niveau là (même si l'installation fût relativement fastidieuse compte tenu du fait que je ne pouvais utiliser ni disquette ou CD, j'ai dû injecter les fichiers d'installation directement dans le disque dur du IBM mais depuis un autre PC ...), DOS et Windows fonctionnent parfaitement j'ai même pu installer le pilote du lecteur CD comme ça je peux au moins utiliser les CD sur cette machine, c'est toujours ça ...

Je me tourne donc vers vous, car après pas mal d'heures consacrées à ce PC, je ne trouve toujours pas de solution. Auriez-vous des suggestions pour m'aider à résoudre ces problèmes ? Je me demande si ces problèmes peuvent être liés et si mes soucis ne viennent pas directement du (ou des) contrôleurs eux-même, mais je ne sais pas si un seul contrôleur gère à la fois les lecteurs de disquette et les ports séries. Et si le contrôleur était en cause, mes compétences en électronique étant limitées ce qui m'empêcherait de résoudre ce problème, pensez-vous que je pourrais tout de même utiliser mon lecteur de disquette en me procurant et en installant une carte contrôleur ISA ?

Je m'excuse pour la longueur de mon message mais je voulais donner un maximum d'informations concernant mon problème.

En vous remerciant d'avance,

Iskeryn.


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème IBM Aptiva 2411-768
Publié : 10 oct. 2018 08:01
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2974
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
En effet ça ressemble à un problème avec la puce de "super Io" (puce qui rassemble les fonctions de port série/parallèle, disquette et parfois IDE, même si ici ça à l'air bon pour l'ide).

Comme tu l'as dit, je pense qu'une carte contrôleur en isa pourrait corriger le problème

_________________

Laptop hater


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2411-768
Publié : 10 oct. 2018 23:21
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Bonsoir,

Merci pour ta réponse, j'essaierai donc de mettre la main sur une telle carte. Étant donné que je n'ai jamais utilisé ce type de carte je me demandais s'il serait toujours possible de faire booter le PC sur une disquette (genre pour utiliser la disquette d'installation de Windows 95 par exemple) ? Ce serait quand même pratique si je devais réinstaller l'OS.

J'ai une seconde question aussi, est-ce qu'il y aurait un moyen de pouvoir me procurer les disques de restauration d'origine pour mon IBM Aptiva (2144-768 SC-L) ? Car j'aimerais pouvoir retrouver les mêmes logiciels que ceux qui étaient installés dessus initialement. En cherchant bien sur Internet j'ai trouvé un disque de restauration IBM pour ce qui semble être un modèle similaire, mais je ne suis pas complètement sûr qu'il corresponde et je pense aussi que le disque que j'ai trouvé est intégralement en Anglais car il est destiné aux versions US des Aptiva.

Merci.


Haut
Profil Citer
DoomQuakeKeen
Sujet du message : Re: Problème IBM Aptiva 2411-768
Publié : 11 oct. 2018 19:08
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2330
Inscription : 05 avr. 2012 17:38
PC Rétro : Amstrad PC2086/30 8086 640K RAM 32Mo RLL
 
J'ai aussi ce genre de machine grâce à 64KNUM mais moi c'est un IBM Aptiva 2168-789 (SL-C) donc pas le même modèle.

Néanmoins si tu veux je peux te faire une copie des images d'installation qu'il m'a donné avec.

Je n'ai pas eu de soucis avec la puce qui gère les I/O jusqu'à présent (je touche du bois) mais c'est une machine qui est quand même très capricieuse.

Pour ma part le lecteur de CD qui est dedans est à priori le seul qui a voulu fonctionner (c'est ce qui m'a été dit lorsque je l'ai récupéré) et je n'ai jamais réussi à y faire fonctionner correctement la moindre carte son.

Si tu as déjà une carte son dedans pourrait tu me donner la référence et si tu n'en as pas déjà bonne chance :lol:

_________________

Vérification de l’orthographe pour Mozilla Firefox : http://addons.mozilla.org/fr/firefox/a ... alecte-fr/
Vérification de l’orthographe pour Google Chrome : http://chrome.google.com/webstore/sear ... ecte?hl=fr
modérateur : [b][color=#00AA00][/color][/b]
administrateur : [b][color=#AA0000][/color][/b]
membre : [b][color=#006699][/color][/b]
[ img ]


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2411-768
Publié : 12 oct. 2018 00:07
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Oh et bien merci beaucoup pour ta proposition c'est très sympa et ça pourrait m'être très utile !

Je ne suis pas complètement sûr que tes disques puissent me servir pour restaurer ma machine étant donné que la mienne est une 2144-768 (SL-C), mais je t'avoue que ça m'intriguerait d'essayer puisque les Aptiva 2144 et 2168 sont souvent cités ensemble dans les documents que j'ai pu trouver. D'après mes recherches tes disques de restaurations devraient avoir 19H2339 comme P/N, ce qui semblerait aussi convenir aux 2144-768 (SL-C) après je me trompe peut-être.

Donc si tu es toujours d'accord et si cela ne te dérange pas, je veux bien que tu me fasses une copie de tes disques, ce serait très gentil de ta part et cela m'aiderait beaucoup.


Tu as bien de la chance de n'avoir jamais rencontré un problème similaire avec la puce qui gère les I/O, car je peux t'assurer que c'est très handicapant et aussi très frustrant haha

En ce qui concerne les lecteurs CD, je n'ai pas eu le moindre souci avec ceux que j'ai essayé dessus (un ASUS de 2001 et un LG de 1999 je crois), ils étaient bien reconnus dans le BIOS. J'ai fini par installer définitivement le LG dans mon Aptiva, car ça me semblait être le plus cohérent notamment à cause de son année de fabrication et aussi car mes parents avaient fait installer un modèle similaire lorsqu'ils utilisaient le IBM à l'époque donc ça colle plus à mes souvenirs, mais c'est un détail. J'ai juste dû fouiller sur Internet pour trouver les bons pilotes. Mais maintenant il fonctionne parfaitement, que ce soit sous DOS ou Windows.

Et oui ! J'ai effectivement une carte son, elle avait été installée à l'époque par le vendeur, il s'agit d'une Maxi Sound 16 de Guillemot apparemment (même si je ne trouve pas de trace du constructeur dans les documents de la carte). Elle fonctionne plus ou moins, j'ai le son de quelques jeux sous DOS mais sous Windows je n'ai rien du tout, il doit y avoir une erreur de configuration, mais étant donné que ma disquette de pilote est presque illisible, je ne saurais dire si déjà j'ai installé la bonne version des pilotes haha. Je vais devoir m'y intéresser de plus près.


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2411-768
Publié : 16 oct. 2018 22:59
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Bonsoir,

Je reviens vers vous, toujours pour mon IBM Aptiva 2144-768 (oui je me suis trompé dans le titre du sujet initial mais je ne sais pas si c'est quelque chose qui peut être modifié ...).

Donc j'ai pu mettre la main sur une carte contrôleur ISA (Chicony CH-101B) pour y connecter mon lecteur de disquette étant donné que la puce Super I/O de la carte mère semble défaillante. J'ai bien pu l'installer dans l'ordinateur et j'ai pu y connecter mon lecteur de disquette. Le lecteur semble bien réagir lorsque le PC tente d'y accéder (par exemple il est bien reconnu par le BIOS, il s'initialise bien lors du démarrage du PC et il réagit lorsque j'essaye d'accéder au contenu d'une disquette sous Windows ou même DOS) cependant il m'est complètement impossible de lire ou même d'écrire une disquette, à chaque fois Windows me dit que la disquette n'est pas formatée et me propose de le faire (ce qui ne fonctionne bien évidemment pas). J'ai bien entendu tester avec d'autres disquettes mais cela ne change rien.

J'ai bien entendu testé la carte contrôleur ainsi que le lecteur de disquette et sa nappe dans une autre machine (Packard Bell CL110) et tout fonctionnait parfaitement.
Mais pour cela j'ai dû désactiver le contrôleur de lecteur de disquettes de la carte mère depuis le BIOS, car sinon j'avais le même résultat qu'avec le IBM.

J'ai pu me procurer la documentation technique de la carte ISA pour pouvoir changer les réglages de la carte grâce aux cavaliers présents sur celle-ci mais cela n'a rien donné pour le IBM. Cependant cela m'a permis de pouvoir désactiver la partie IDE de la carte (pour les disques durs) afin que je puisse utiliser un maximum du matériel d'origine du IBM. De cette manière juste le contrôleur du lecteur de disquette est remplacé par la carte. J'ai aussi tenté de changer l'adresse du lecteur (de 3F0-3F7h à 370-377h) grâce à ces cavaliers mais quand je fais ça le lecteur n'est plus détecté et il ne réagit plus du tout.

Je pense donc que, la carte contrôleur ISA entre en conflit avec la puce Super I/O ce qui empêche donc le PC de lire et d'écrire les disquettes. Mais contrairement à mon Packard Bell, je ne trouve pas comment désactiver la puce contrôleur intégrée à la carte mère, aucun cavalier semble pouvoir agir là-dessus et je ne trouve pas d'option correspondante dans le BIOS.

Auriez-vous une solution à me proposer ? Suis-je passé à côté de quelque chose ? Je vous avoue que je commence peu à peu à perdre espoir pour ce IBM ...

Merci d'avance.


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 16 oct. 2018 23:16
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2974
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
Je suis en train de subir le même genre de choses sur mon DX4 (celui que j'ai restauré récemment). Depuis que je l'ai mis dans un boîtier, il ne veut plus lire les disquettes convenablement ... sauf que le mien n'a pas de contrôleur intégré, du coup je me demande si la configuration des cavaliers pour le CPU (que j'ai changé depuis) n'est pas en faute ? (je n'en suis pas sûr, mais c'est la seule chose que je peux tester, j'espère que ma carte n'a pas tout simplement cramé pour je ne sais quelle raison)

Quel rapport avec ton IBM ? Eh bien peut-être que c'est le même genre de soucis à la con ?

Vérifies que tous les cavaliers sont bien à leur place ...

Autre question : quel type de mémoire utilises-tu ? Car il y a eu DEUX types de mémoire en SIMM 72 broches : la FPM (plus vieille) et l'EDO.

Problème ... Y'a aucune différence visuelle entre les deux, et certaines cartes supportent les deux standards ... D'autres non ... Et enfin certaines réagissent très bizarrement quand on leur met de l'edo. Qui sais, peut-être est-ce une étrangeté du genre ?

Encore une chose : as-tu essayé d'enlever toutes les cartes d'extensions et périphériques qui étaient inutiles à ce genre de tests ? (que ce soit pour tester le contrôleur interne ou le contrôleur sur la carte d'extension)

_________________

Laptop hater


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 17 oct. 2018 13:47
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Oui peut-être que la configuration des cavaliers du processeur est en cause, je sais que pour ma part, mettre un des cavaliers du processeur dans une certaine position entraînait des crashs et des reboot sans que cela empêche l'ordinateur de démarrer (mais cela posait problème pour Windows par contre). Le cavalier en question permet de changer la vitesse du CPU (50 Mhz dans une position et 66 Mhz dans l'autre) et les problèmes survenaient quand je passais en mode 66 Mhz. Après je ne sais pas du tout si les cavaliers sont bien la cause de ton problème.

En ce qui me concerne j'ai déjà vérifié de nombreuses fois les cavaliers ainsi que leur fonction en me référent à la documentation technique IBM, aucun semble pouvoir désactiver le contrôleur interne. Pareil pour les cavaliers de configuration du processeur, ils sont positionnés comme ils le devraient avec un 486DX2. Par contre, parmi les cavaliers de configuration du processeur (qui sont au nombre de 3 sur la carte-mère de Type C-1 sur le 2144-768) je remarque que l'un d'eux ne semble pas changer grand chose (le cavalier J24 pour être plus précis), je ne sais pas exactement à quoi il sert mais je sais qu'il est lié au processeur, mais peu importe sa position, l'ordinateur fonctionne toujours de la même manière.

En termes de mémoire, j'ai dans ce PC 16Mo, 2 barrettes de 8Mo. Les RAM qui sont installées sont deux Texas Instruments TM248CBK32U-60, il semblerait qu'elles soient de type EDO, en tout cas c'est ce que j'ai pu lire sur Internet mais je n'en suis pas vraiment sûr. Je ne pense pas que ces barrettes soient celles d'origine mais elles y sont installées depuis longtemps (vers 1997-1998 je pense). Elles étaient donc là bien avant l'apparition de mes problèmes.

J'ai même tenté de démarrer mon Aptiva avec les RAM de mon Packard Bell puisqu'elles ont l'air similaire, mais le IBM n'a même pas voulu afficher quoi que ce soit. Pareil pour quand je mets les RAM de mon Aptiva dans mon Packard Bell. Elles comportent toutes le même nombre de PIN (72), ont l'encoche au même endroit et font aussi la même taille mais elles ont l'air incompatibles ...

Et oui, j'ai bien évidemment testé avec aucun autre périphérique que le lecteur disquette (connecté soit directement à la carte-mère soit à la carte contrôleur ISA) mais cela ne change rien. Quand le lecteur de disquette est connecté à la carte mère, celle-ci ne le détecte même pas et quand il est branché à la carte contrôleur il est détecté et réagi mais il m'est impossible de lire ou même d'écrire quoi que ce soit.
J'ai même essayé en branchant le lecteur disquette à la carte mère mais en ayant quand même la carte contrôleur ISA installé ... oui j'en suis à ce niveau de désespoir haha


Haut
Profil Citer
nintenloup
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 19:32
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2241
Inscription : 06 janv. 2013 05:02
PC Rétro : Tandy 1000 SX, V20, 640k, AdLib, CGA/TGA, rll 33mo
 
Si vous changez la vitesse du fsb, ça pourraist simplement estre le controsleur ne fonctionne pas bien à ce fsb, point.

T'as fait un tour dans le bios ? J'ai fait un survol du sujet, j'ai peut-estre passé par dessus.

_________________

L’homme est un loup pour l’homme, ce qui, vous en conviendrez, n’est pas très gentil pour le loup.

Ma chaîne youtube française sur les vieux ordinateurs et autres vieilles technologies.


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 19:53
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2974
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
À mon avis c'est surtout qu'il a un DX2 50 qui n'est pas stable à 66MHz.

_________________

Laptop hater


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 22:14
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Je t'avoue que je n'ai aucune idée de comment changer la vitesse du FSB, je n'ai vu cette option nulle part que ce soit dans le BIOS ou même avec les cavaliers.
Oui j'ai absolument tout regardé dans le BIOS, il n'y a pas énormément d'options d'ailleurs, juste quatre pages et très peu mentionne le lecteur de disquette, à part pour la séquence de démarrage et aussi pour le type de lecteur. J'ai d'ailleurs tenté de retirer le lecteur de disquette de la séquence de démarrage pour voir si cela changeait quelque chose mais non, pareil pour le type de lecteur, si je modifie l'option dans le BIOS (ou même que je désactive le lecteur depuis les paramètres), le lecteur réapparaîtra quand même.

En ce qui concerne la vitesse de mon processeur, je ne l'ai pas changée, par défaut elle est à 50 Mhz, j'utilise donc l'ordinateur avec sa vitesse par défaut.
J'ai simplement mentionné le fait que je pouvais, si je le voulais, activer un mode 66 Mhz, que j'ai essayé juste pour voir. Résultat l'ordinateur est moins stable en mode 66 Mhz donc j'ai remis ces paramètres d'origine (50 Mhz) comme ça la machine fonctionne comme elle le devrait, excepté pour mon soucis de lecteur de disquettes.


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 23:12
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2974
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
Eh bien justement ce cavalier modifie le FSB ^^

Le 486 DX2-50 prends comme FSB 25MHz et le double pour atteindre les 50MHz annoncés. Pour atteindre 66MHz, il faut donc avoir un FSB de 33MHz.

Si tu avais un 486 DX-33, il te faudrait régler le FSB à 33MHz, sinon il tournera à 25MHz :)

_________________

Laptop hater


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 23:14
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 304
Inscription : 19 mars 2016 20:33
PC Rétro : PCs trop récent pour être spécifié ici
 
Ça ne peut pas régler son pb de lecteur disquette.

_________________

Si il n'y a pas d'accent, c'est que ce message à été envoyé depuis un navigateur textuel.

Aide-mémoire :
[b][color=#AA0000]Administrateur[/color][/b] Couleur AA0000
[b][color=#00AA00]Modérateur[/color][/b] Couleur 00AA00
[b][color=#006699]Membre[/color][/b] Couleur 006699


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 23:19
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2974
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
J'ai pas dit le contraire, j'explique juste un truc :lol:

_________________

Laptop hater


Haut
Profil Citer
Joet BERNARD
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 18 oct. 2018 23:28
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 304
Inscription : 19 mars 2016 20:33
PC Rétro : PCs trop récent pour être spécifié ici
 
Si son pc est instable à 66 MHz, comme toute personne censé, il va préférer l'utiliser en 50 :lol:
Mais oui c'est quand même bon à dire qui sais, ça se trouve qu'il va en trouver un 486 DX66 ( :uh: je sais pas si je le dit bien...) Il n'empêche ça ne règle pas le pb principal, celui pourquoi il a fait appel à nous dans ce topic, càd un lecteur disquette qui ne fonctionne pas sur cette CM là.

_________________

Si il n'y a pas d'accent, c'est que ce message à été envoyé depuis un navigateur textuel.

Aide-mémoire :
[b][color=#AA0000]Administrateur[/color][/b] Couleur AA0000
[b][color=#00AA00]Modérateur[/color][/b] Couleur 00AA00
[b][color=#006699]Membre[/color][/b] Couleur 006699


Haut
Profil Citer
Iskeryn
Sujet du message : Re: Problème IBM Aptiva 2144-768
Publié : 19 oct. 2018 00:03
Membre inscrit
Hors-ligne
 
Messages : 7
Inscription : 17 août 2016 19:40
 
Ahh ! Et bien merci au moins j'aurai appris quelque chose :D

Donc du coup non, le changement de FSB ne donne rien pour ce qui est de mon problème de lecteur disquettes.

Et non, je ne chercherai pas de 486DX2 66Mhz, j'aimerais pouvoir refaire fonctionner l'ordinateur dans son état d'origine. Enfin plutôt dans l'état dans lequel je l'ai reçu il y a plusieurs années. Il fonctionnait correctement quand je l'ai eu et j'aimerai pouvoir faire en sorte que cela redevienne ainsi. Même si bon, je ne respecte déjà plus vraiment cette règle étant donné que j'ai dû ajouter une carte contrôleur ISA.


Haut
Profil Citer
Afficher : Trier par : Ordre :
Répondre   Page 1 sur 1  [ 16 messages ]
Revenir à « Informatique des vieux systèmes »
Aller :