Win3x.Org

Windows & DOS Community

Problème d'installation Win32s sur windows 3.1

Règles du forum

Pour tout sujet impliquant un système d'exploitation daté de 2000 à nos jours, merci de le publier dans la section intitulée « Informatique moderne ».

Répondre   Page 1 sur 1  [ 7 messages ]
Auteur Message
jacques531
Sujet du message : Problème d'installation Win32s sur windows 3.1
Publié : 21 mai 2018 17:58
Membre inscrit
Hors-ligne
 
Messages : 3
Inscription : 03 mai 2018 20:44
 
Bonjour à tous,
Après avoir installé à plusieurs reprises et avec des versions différentes win32s je me retrouve toujours avec la même erreur :
"ERREUR DE CHARGEMENT USERS.EXE"
Quelqu'un aurait il déjà eu ce souci ?
Ma Config : Portable Dell Inspiron 2650
Pentium (R) 4-M 1.7/1.2 GHz
256 MB Mémoire
16 MB Mémoire Vidéo

Merci pour votre collaboration.


Haut
Profil Citer
michel
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 21 mai 2018 19:05
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 2570
Inscription : 07 févr. 2003 19:46
PC Rétro : IBMPS2 mod85-DOS 6.22 - Windows 3.11 fwg
 
Avant chaque nouvelle installation de Win32s il faut désinstaller la précédente version manuellement (à la main car windows ne possède pas de désinstallateur pour cette application).
Procéder comme indiqué ci-dessous.

Editer le fichier SYSTEM.INI et dans la section [386Enh] supprimer la ligne
device=<WINDOWS>\<SYSTEM>\win32s\w32s.386 (où Windows et System sont normalement les répertoires où votre Windows est installé.

Toujours dans ce même fichier System.ini, dans la section [BOOT) remplacer la ligne
drivers=mmsystem.dll winmm16.dll
par
drivers=mmsystem.dll

Enregistrez le fichier.

Attends, c'est pas fini :
Sous DOS, supprimer les fichiers suivant du répertoire \windows\system\ :
WINMM16.DLL
W32SYS.DLL
WIN32S16.DLL
WIN32S.INI
WINHLP32.EXE
WINDOWS.HLP
WINHLP32.HLP
WINHLP32.CNT

Puis supprimer le répertoire Win32s se trouvant dans le répertoire \System\ de Windows.

Eteindre le PC et rédémarrer. Installer la version suvante. La dernière étant la 1.30c.

_________________

clikicitoraleur


Haut
Profil Citer
jacques531
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 21 mai 2018 19:52
Membre inscrit
Hors-ligne
 
Messages : 3
Inscription : 03 mai 2018 20:44
 
Bonsoir Michel,
Autant pour moi car je ne l'avais pas précisé maistoute la procédure que vous cité a été faite entre chaque installation de version.
Merci pour votre réponse.


Haut
Profil Citer
Deksor
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 21 mai 2018 20:44
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3707
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
Je me demande si la vitesse du processeur ne pourrait pas être en cause ici ...

Rien ne dit que c'est ça, mais faire fonctionner un système sorti à une époque où le processeur le plus rapide devait aller à 66MHz sur un processeur à presque 2GHz c'est pas impossible que ça pose problème pour certaines choses.

Peut-être que quelqu'un d'autre ici avec un Pentium 4 pourrait essayer pour voir ?


Ps : Bienvenue sur win3x.org :)

_________________

Laptop hater


Haut
Profil Citer
Big Monstro
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 22 mai 2018 00:47
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3224
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 95
 
Bonsoir jacques531 et bienvenue à Win3x.Org !
jacques531 a écrit : *  21 mai 2018 17:58
Après avoir installé à plusieurs reprises et avec des versions différentes win32s je me retrouve toujours avec la même erreur :
"ERREUR DE CHARGEMENT USERS.EXE" (...)
Ma Config : Portable Dell Inspiron 2650
Pentium (R) 4-M 1.7/1.2 GHz
256 MB Mémoire
Je suppose que vous voulez parler du fichier USER.EXE (et non pas USERS.EXE), qui est un fichier système indispensable du système d'exploitation (il suffit de renommer ce fichier, localisé dans le sous-répertoire SYSTEM, pour que Windows refuse purement et simplement de démarrer, et obtenir le même message d'erreur que vous).

Windows 3.1 n'a pas de problème connu avec les processeurs (relativement) modernes, contrairement à Windows 95 et à la première édition de Windows 98, mais les extensions Win32s empêchent manifestement le démarrage sur votre système (je présume que si vous démarrez Windows en mode standard 80286 - commande win /s - le lancement aura lieu comme avant l'installation des Win32s puisque ceux-ci seront désactivés). Essayez de voir ce qu'il se passe si vous chargez le programme AT-SLOW en mémoire avant de lancer Windows (commande AT-SLOW /t1999 pour ralentir au maximum)
:arrow: Télécharger AT-SLOW 4.0 en cliquant ici
Une autre hypothèse étant que le souci vienne de votre mémoire trop importante. Si AT-SLOW ne marche pas, désinstallez les Win32s, démarrez Windows "normalement" (l'option "386 étendu" n'est pas disponible dans le panneau de configuration en mode standard 80286) et désactivez ensuite complètement la mémoire virtuelle (gestionnaire de programmes > groupe principal > panneau de configuration > 386 étendu > mémoire virtuelle... > changement>> Type: aucun. Windows redémarrera pour que les modifications soient prises en compte. Pour mémoire, Windows 3.1 ne peut pas gérer plus 256 Mo de mémoire au total (physique + virtuel) :arrow: http://support.microsoft.com/kb/84388

Cordialement,
Big Monstro


Haut
Profil Citer
jacques531
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 22 mai 2018 11:21
Membre inscrit
Hors-ligne
 
Messages : 3
Inscription : 03 mai 2018 20:44
 
Merci pour vos propositions.
Effectivement j'ai commis une erreur d'écriture sur "USER(S)".
Le programme AT-SLOW n'a eu aucun effet sur le chargement de "USER". J'ai toujours le même message d'erreur.
Par la suite j'ai désinstaller win32s de façon à désactiver la mémoire virtuelle mais win32s à refusé de s'installer sans cette mémoire.

Je pense qu'il y'a un conflit entre mon Dell Inspiron 2650 et windows 3.1. Si je trouve une explication je ne manquerai pas de tenir informé.


Haut
Profil Citer
Big Monstro
Sujet du message : Re: Problème d'installation Win32s sur windows 3.1
Publié : 22 mai 2018 11:34
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3224
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 95
 
Dommage que AT-SLOW n'a pas changé votre situation. En même temps, je l'utilise pour ralentir mon Pentium III 550 MHz de 1999. Votre machine étant plus rapide et récente, il se peut que cela ne suffit pas. En outre, AT-SLOW est très dépend du matériel sur lequel il est exécuté. Ce logiciel n'a strictement aucun effet dans une machine virtuelle (du moins avec les logiciels que j'ai testé), par exemple.

Juste par curiosité (et peut être contribuer à mieux comprendre le problème) : quelle version de DOS utilisez-vous ? Ce n'est pas mentionné dans vos messages. MS-DOS 5.x ne peut pas gérer plus de 16 Mo de RAM, MS-DOS 6.x est limité à 64 Mo tandis que MS-DOS 7.x peut voir bien au-delà (en principe jusqu'à 4 Go). Si vous exécutez Windows 3.1 depuis MS-DOS 7.x (possible nativement avec DOS 7.0 ou après avoir patché DOS 7.1 pour autoriser l'exécution de Windows 3.1), vous devrez avoir vos 256 Mo de RAM de reconnu. Ajouté à cela la mémoire dite virtuelle, vous êtes au-delà de la quantité maximale gérée par Windows 3.1 selon Microsoft : http://support.microsoft.com/kb/84388

Sauf erreur de ma part, les extensions Win32s n'ont jamais été utilisées pour faire tourner des logiciels aux graphismes (relativement) poussés. Peut être que l'émulation/virtualisation conviendrait mieux à vos attentes, en supposant qu'une incompatibilité matérielle quelconque empêche l'exécution de Windows 3.1 avec ces extensions (avec la virtualisation, seule la compatibilité avec le processeur hôte importe, les autres composants sont émulés).


Haut
Profil
Afficher : Trier par : Ordre :
Répondre   Page 1 sur 1  [ 7 messages ]
Revenir à « Informatique des vieux systèmes »
Aller :