Win3x.Org

Windows & DOS Community

Un Compaq LTE 5300 rejoint mon LTE 5000

Règles du forum

Pour tout sujet impliquant un système d'exploitation daté de 2000 à nos jours, merci de le publier dans la section intitulée « Informatique moderne ».

Répondre   Page 1 sur 1  [ 7 messages ]
Auteur Message
Romano2K
Sujet du message : Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 25 nov. 2020 03:30
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 29
Inscription : 27 mai 2019 17:32
PC Rétro : Compaq LTE 5000
 
Bonjour à tous !

En juin 2019 un oncle me donnait le Compaq LTE 5000 sur lequel j'avais découvert internet à la fin des années 1990. Je m'étais amusé à remplacer le disque dur fatigué par une carte CompactFlash, à réinstaller Windows 95 et à racheter une souris Microsoft IntelliMouse neuve (pour 15 euros) ainsi qu'une carte PCMCIA Xircom CreditCard Ethernet 10/100 + Modem 56 (CEM56-100) neuve (20 euros).

Cet ordinateur n'était qu'un ordinateur parmi d'autres pour mon oncle, qui n'avait pas particulièrement veillé à sa préservation jusqu'en 2019. Mais il est symbolique pour moi, donc j'étais un peu frustré que la coque ait jauni, que le capot soit rayé, que le capuchon du trackpoint soit manquant et que les haut-parleurs soient défaillants.

Et indépendamment de sa portée symbolique pour moi, le Compaq LTE 5000 est un des ordinateurs des années 1990 que je préfère, pour son esthétique intemporelle et pour sa conception. J'ai donc créé une alerte "Compaq LTE" sur eBay pour trouver un meilleur Compaq de la série LTE 5000. Je convoitais un LTE 5400, le dernier représentant de la série, combinant écran TFT SVGA 12,1 pouces et processeur Pentium 150 MHz, contre TFT VGA de 10,4 pouces et Pentium 75 MHz pour le LTE 5000.

Mais après quelques mois à voir défiler toutes sortes de modèles en mauvais état, j'ai fini par acheter en juin 2020 à un Belge un LTE 5300 en super état fourni avec la sacoche, l'adaptateur secteur mais aussi le cordon d'alimentation d'origine. Seule différence avec le LTE 5400 : le processeur est cadencé à 133 MHz. J'ai aussi acheté pour 100 euros une station d'accueil MultiBay Expansion Base (pas la version ISA), en grande partie car elle s'accompagnait du lecteur de CD-ROM que je n'avais pas encore. Et enfin pour 30 euros un clavier Azerty français neuf, que je n'ai toujours pas installé.

IMG_0474.jpeg

Je n'avais pas vraiment utilisé ce LTE 5300 jusqu'à maintenant. Puis j'ai récupéré un PC Engines ALIX.2, un single board computer destiné à servir de routeur, sur lequel on installe un système d'exploitation comme OpenWrt ou OPNsense via une console série. Comme j'ai rencontré des difficultés à trouver un adaptateur USB vers RS-232 qui fonctionne, j'ai pensé que c'était l'occasion d'acheter un câble null modem et d'utiliser le Compaq LTE 5300 comme terminal pour le routeur. J'en ai profité pour acheter un nouvel adaptateur CF vers IDE 44 broches PC Engines (référence CF2G) ainsi qu'une nouvelle carte Transcend CompactFlash 133x de 4 Go (référence TS4GCF133).

Voilà pour la "petite" histoire, qui je l'espère vous fait profiter de ma joie et de mon excitation !

PC Engines ALIX.2 (alix2d3)
Console série HyperTerminal.png


J'écris aussi pour vous soumettre quelques problèmes et quelques questions ! :-)

1. Comme j'ai déjà redécouvert Windows 95 en 2019 sur le LTE 5000, j'ai pensé que je pouvais profiter de la remise en route du LTE 5300 pour redécouvrir Windows 98. J'ai créé et formaté une partition FAT32 à l'aide d'une disquette de démarrage Windows 98 SE, copié le dossier WIN98 du CD de Windows 98 SE téléchargé ici sur la CF via mon ordinateur moderne, puis installé avec succès Windows 98 SE sur le LTE 5300. Les pilotes de la carte graphique et de la carte son sont intégrés à Windows 98 SE ! Puis j'ai activé le contrôleur PCMCIA, inséré ma carte réseau Xircom et installé les pilotes.
Problème : tout fonctionne, mais j'ai des freezes toutes les quelques secondes tant qu'un câble réseau est branché et que l'ordinateur est connecté à mon réseau local. Avez-vous une idée de comment résoudre ce problème ?

2. J'ai donc installé Windows 95 OSR 2 (sans les Internet Explorer 4, Active Desktop et "Installation de OEM pour MSN" d'OSR 2.5), et je n'ai aucun freeze même connecté au réseau local. En revanche je n'arrive pas à faire fonctionne le chipset audio ESS ES1688 AudioDrive ! Le gestionnaire de périphériques indique "Ce périphérique est manquant, ne fonctionne pas convenablement ou certains des pilotes nécessaires à son utilisation n'ont pas été installés. Consultez la documentation accompagnant votre matériel. (Code 10.)" Si j'essaie d'installer les pilotes fournis par Compaq via le "SoftPaq" SP1860, Windows me dit en substance que les pilotes qu'il intègre sont plus récents que ceux du SoftPaq. Comment faire ?

3. Alors que Windows 95 répond instantanément sur le LTE 5000, Windows 98 SE est moins réactif sur le LTE 5300, du moins en explorant des dossiers avec Active Desktop.
Mais utiliser l'un puis l'autre me fait réaliser que Windows 98 est sacrément plus moderne que Windows 95.
Si on trouvait une solution aux freezes sur Windows 98 SE, quel OS me conseilleriez-vous et pourquoi ?

4. Existe-t-il un moyen de réinstaller Windows 95 tel qu'il était installé d'origine, avec toute la panoplie de logiciels fournis par Compaq ?

5. Quand je ressors et rebranche mes LTE 5000 ou LTE 5300 après plusieurs heures sans utilisation, ils se plaignent au démarrage et perdent la date et l'heure. Je suppose que c'est la pile qui est à plat, mais je n'ai pas trouvé les instructions de remplacement. Idem pour le clavier. Avez-vous des pistes ?

6. Enfin, je cherche des solutions pour transférer des fichiers plus pratiques qu'extraire la CF du caddie du disque dur.
6.1. Avec le LTE 5000 et la carte réseau, j'avais réactivé SMBv1 sur mon PC Windows 10 et je pouvais accéder depuis Windows 10 à C: partagé par le LTE 5000. Mais ensuite je ne pouvais plus accéder à mon NAS via SMBv2 ou SMBv3 depuis mon PC Windows 10, et je n'ai jamais réussi à résoudre cette incompatibilité autrement qu'en réinstallant Windows 10. Avez-vous d'autres suggestions via le réseau ?
6.2. Est-ce qu'il existe un équivalent de LapLink V, logiciel de transfert de fichiers par câble null modem, mais fonctionnant entre Windows 95 ou Windows 98 et un ordinateur moderne exécutant Windows 10, macOS ou Linux (Raspberry Pi), sachant que j'ai trouvé entre temps un adaptateur USB vers RS-232 qui fonctionne ?
6.3. Puis-je utiliser une carte CompactFlash d'un côté dans un adaptateur CF vers PCMCIA et de l'autre dans un lecteur de carte mémoire USB ?

Merci par avance pour vos précieux conseils ! :)

Dernière modification par Romano2K le 25 nov. 2020 03:33, modifié 1 fois.

Haut
Profil Citer
Deksor
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 25 nov. 2020 09:47
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 4970
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
1: Vas voir dans le gestionnaire de périphériques si dans les disques durs, le disque C a la case "DMA" cochée ou pas. Si elle ne l'est pas, coches-la.
Pas sûr que ça résolve ton problème mais peut-être que oui (et ça devrait améliorer les perfs sous 98 ^^)

2: Quel pilote as-tu installé avant ?

3: Comme tu le dis, windows 98 est mieux fichu que 95. Le problème c'est qu'il est plus lourd comme tu l'as remarqué.
En dehors d'améliorations visuelles, je ne suis pas sûr que 98 t'apporte grand chose pour ce PC (il améliore le support de l'USB, des cartes graphiques 3D, supporte les dernières versions de DirectX, bref que des choses que ce PC n'a pas ^^)

4: il faudrait trouver les master CD, ou peut-être que si le vieux disque de ton oncle fonctionne encore, et que c'est l'installation d'origine dessus peut-être que tu peux la cloner puis la restaurer ? J'ai fait ça avec mon Toshiba 210CDS, j'ai pris le disque dur d'un Toshiba 200CDS, j'ai viré tous les documents personnels et les programmes inutiles et ensuite j'ai cloné le tout.

5: il y a peut-être un manuel de service dispo en ligne ? La pile ne doit pas être cachée très profondément dans l'ordi de toute façon.

6.1: La solution que j'ai trouvé et que j'utilise, c'est de faire un "mini nas" avec ce qu'on a sous la main (j'ai pris un raspberry pi) et d'y installer samba. Comme ça le pi est accessible depuis 9x et depuis Windows 10 sans pour autant compromettre l'un ou l'autre.
Sinon tu peux aussi essayer le serveur FTP. Tu le lances sur l'un ou l'autre et ensuite sur le deuxième ordi tu utilises un client FTP (l'explorateur de fichiers de windows en est un)

6.2: Normalement il y a un logiciel par défaut dans Windows qui fait ça et qui je pense ne fait rien de propriétaire. Après le nullmodem c'est vraiment très très lent.

6.3: Bien sûr !

_________________

Laptop hater


Haut
Profil Citer
Big Monstro
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 25 nov. 2020 22:09
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3511
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 3.11
 
Romano2K a écrit : *  25 nov. 2020 03:30
Problème : tout fonctionne, mais j'ai des freezes toutes les quelques secondes tant qu'un câble réseau est branché et que l'ordinateur est connecté à mon réseau local. Avez-vous une idée de comment résoudre ce problème ?
Je pense que tu devrais vérifier la configuration de la carte réseau sous Windows 98, notamment le pilote et les ressources allouées (IRQ, etc., éventuellement en conflit avec un autre composant dû à une mauvaise configuration Plug&Pray par défaut). Que l'ordinateur soit plus lent sous Windows 98 n'est pas étonnant mais ces freezes ne devraient pas se produire pour autant. Surtout que tu indiques que ce phénomène ne se produirait QUE lorsque le câble réseau est branché. Cela me semble évident qu'il y a un souci bien spécifique en lien avec la carte réseau
Deksor a écrit : *  25 nov. 2020 09:47
En dehors d'améliorations visuelles, je ne suis pas sûr que 98 t'apporte grand chose pour ce PC (il améliore le support de l'USB, des cartes graphiques 3D, supporte les dernières versions de DirectX, bref que des choses que ce PC n'a pas ^^)
Windows 98 apporte aussi une meilleure compatibilité logicielle que son prédécesseur (cependant, les logiciels Win32 incompatibles avec Windows 95 risquent d'être trop récents et donc pas vraiment prévus pour être utilisés sur un Pentium 133...). Enfin, Windows 98SE serait (parait-il) un peu plus stable que Windows 95 (cela reste néanmoins un Windows 9x...).

Sauf besoin particulier justifiant la mise à jour, se contenter de Windows 95 devrait être la meilleure option (ou alors essayer Windows NT4 : il a le même GUI que 95, mais il demande plus de mémoire). Il peut aussi envisager d'alléger l'interface de Windows 98 via cet utilitaire => http://www.litepc.com/98lite.html


Haut
Profil Citer
Deksor
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 26 nov. 2020 10:28
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 4970
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
Citation :
Windows 98 apporte aussi une meilleure compatibilité logicielle que son prédécesseur (cependant, les logiciels Win32 incompatibles avec Windows 95 risquent d'être trop récents et donc pas vraiment prévus pour être utilisés sur un Pentium 133...).
C'était aussi un peu le sens de mon propos :)

La compatibilité meilleure supposée de windows 98 n'apportera pas grand chose d'intéressant pour un Pentium 133

Après il se peut que 98 lite soit plus véloce que 95.
98 est plus optimisé en son cœur, mais le gain de performances est contrebalancé par l'explorateur de fichiers beaucoup plus lourd que sous 95. Comme 98 lite retire cela, on retrouve alors un OS beaucoup plus rapide

_________________

Laptop hater


Haut
Profil Citer
Romano2K
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 26 nov. 2020 23:11
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 29
Inscription : 27 mai 2019 17:32
PC Rétro : Compaq LTE 5000
 
Bonsoir !

Je vous remercie pour votre accueil toujours aussi chaleureux et pour vos réponses :)

1. Concernant les freezes sur Windows 98, j'ai pensé à un conflit matériel, mais j'ai été épargné du temps où j'utilisais Windows 9x, ou bien je contournais autrement car j'étais adolescent et je n'avais pas encore les compétences, donc je ne sais pas concrètement ce qu'il faut faire. Comment vérifier s'il y a un conflit d'IRQ ? Comment le résoudre ?

3. Je ne connaissais pas 98lite, je vais essayer ce week-end ! Il semble qu'il permette d'obtenir un bon compromis entre 95 et 98.
Je m'assurerai que DMA est activé. :)

2. Concernant le son sur Windows 95 OSR 2 : j'ai installé le SoftPaq SP2265 "Supplemental Programs", a priori sans rapport, dans l'espoir de réinstaller quelques logiciels d'origine. Au redémarrage, le pilote du port infrarouge a été réinstallé/mis à jour, et le son fonctionnait avec le pilote présélectionné. Je n'ai pas très bien compris ce qui s'est produit !

4. Je pensais que je retrouverai facilement une image à restaurer donc je n'avais pas sauvegardé le disque dur de mon oncle, sur lequel il me semble pourtant qu'il y avait les logiciels d'origine Compaq. Mais je prends bonne note du mot-clé "master CD" que j'avais oublié !

5. J'ai trouvé de la documentation, mais ce n'est pas une pile "CR" standard. Je vais me renseigner sur un groupe Facebook privé que je viens de rejoindre, dédié aux propriétaires de Compaq LTE et Armada. J'ai vu passer des posts du fondateur du groupe qui a même réussi à refaire une batterie opérationnelle !

6.1. Pour Samba sur un Raspberry Pi, si je comprends bien tu peux le configurer pour qu'il accepte à la fois SMBv1 pour Windows 9x et SMBv2 pour Windows 10 ?
Bonne idée aussi FTP ! Dans quel sens tu me conseilles de le faire ?

6.2. Il y a un logiciel intégré à Windows 9x, mais quel logiciel utiliser côté Windows 10 ou macOS ?

6.3. J'ai commandé et reçu un adaptateur Transcend CompactFlash Adapter (TS0MCF2PC) et une 3e carte Transcend CompactFlash 133x de 4 Go (TS4GCF133), et ça marche parfaitement !


Haut
Profil Citer
Deksor
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 26 nov. 2020 23:29
Modérateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 4970
Inscription : 23 mai 2011 13:33
PC Rétro : 486DX 33 8mo SB Pro 2, P2 450 128mo Voodoo 2 SLI
 
Entre le serveur samba et FTP, je dirais que le serveur FTP est plus compatible avec tout ce que l'on veut vis à vis du serveur samba, en revanche le lien entre les "deux mondes" se fait moins bien je trouve qu'avec un serveur samba.
Sur le serveur samba quand je m'y connecte avec l'explorateur, si un exécutable se trouve sur le serveur par exemple, je peux l'exécuter à distance. En revanche pour le FTP ça ne marche pas.
Par contre le FTP est utilisable sur n'importe quel PC, aussi bien un 8088 sous DOS qu'un PC de 2020, ou encore un mac, un amiga ...
Aussi il se peut que samba ait été mis à jour et qu'il ne supporte plus le SMB1, je ne sais pas trop ce qu'il en est exactement, mais c'est à tester ...
En tout cas mon raspberry pi tourne comme ça depuis des années et je n'ai aucun soucis.

Pour le logiciel de transfert par nullmodem, peut-être qu'il est possible de copier le logiciel pour 95 sur un PC sous Windows 10 et l'exécuter directement ? Ou alors peut-être qu'avec le logiciel "putty" on peut y arriver ...
Je n'ai jamais essayé tout ça pour les problèmes évoqués plus tôt mais je donne quelques pistes ^^

_________________

Laptop hater


Haut
Profil Citer
Romano2K
Sujet du message : Re: Un Compaq LTE 5300 rejoint mon LTE 5000
Publié : 30 nov. 2020 02:24
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 29
Inscription : 27 mai 2019 17:32
PC Rétro : Compaq LTE 5000
 
Bonsoir !

C'est certain que le protocole SMB est plus souple !

SMBv1 est désactivé par défaut depuis Samba 4.11.0, sortie le 17 septembre 2019, mais aux dernières nouvelles on pouvait toujours l'activer explicitement.

Je vais ressortir un de mes deux Raspberry Pi pour faire le point et voir dans quelle mesure SMBv1 d'une part et v2 voire v3 d'autre part peuvent cohabiter, pour éventuellement reproduire la configuration sur mon NAS Synology si ça fonctionne bien.



Concernant les transferts de fichiers via liaison série, j'ai découvert l'existence des protocoles XMODEM, YMODEM, ZMODEM et Kermit, qui sont pris en charge par différents logiciels anciens et modernes.

C'est le cas notamment d'HyperTerminal, dont je découvre qu'il est encore en vente (65 $ !) et qu'il fonctionne sur Windows 10 !

Je chercherai à l'occasion si un logiciel plus moderne existe sur Windows 10, macOS ou Linux, je vous dirai !



J'ai acheté 98lite (25 $ !) pour pouvoir essayer toutes les options, dont le mode "micro" qui permet d'obtenir un Windows 98 super léger (40 Mo !). J'ai commencé à bricoler sur VirtualBox, puis sur le LTE 5300.



Mais j'ai retrouvé le problème de freezes avec ma carte réseau PCMCIA sur la nouvelle installation de Windows 98, et j'aimerais résoudre ce problème avent de décider quel OS installer. Ce qui renvoie à ma question 1 : comment diagnostiquer un éventuel conflit matériel ?

J'ai déjà exploré le gestionnaire de périphériques à la recherche de conflits. J'ai repéré que "Network of Xircom Ethernet 10/100+Modem 56" et "Standard PCMCIA Card Modem" utilisaient tous les deux les mêmes "plages d'entrée/sortie", mais une IRQ différente. Que faire ? :)



Dans le même registre, j'ai un écran bleu pendant le chargement de Windows 98 modifié par 98lite que je n'avais jamais eu, et que je peux ignorer, mais dont j'aimerais me débarrasser. Avez-vous une idée ?

Pièces jointes
IMG_0516.jpeg
IMG_0515.jpeg
IMG_0514.jpeg


Haut
Profil
Afficher : Trier par : Ordre :
Répondre   Page 1 sur 1  [ 7 messages ]
Revenir à « Informatique des vieux systèmes »
Aller :