Win3x.Org
http://www.win3x.org/win3board/

[Résolu] Problème installation et configuration de Windows 3.11 sous DOSBox
http://www.win3x.org/win3board/viewtopic.php?f=84&t=25788
Page 1 sur 1
Auteur :  Fireboy3000 [ 09 mars 2018 14:11 ]
Sujet du message :  [Résolu] Problème installation et configuration de Windows 3.11 sous DOSBox

Bonjour tout le monde :wave: .
Je tente de me relancer dans la virtualisation grâce aux machines virtuelles présentes sur le forum mais je n'arrive pas à exécuter VirtualBox.
Quand je l'exécute, j'ai juste la souris qui mouline un peu et c'est tout, il ne se passe rien :uh: . J'ai essayé les paramètres de compatibilité mais ça ne fonctionne jamais ce truc là... :evil:
J'avais aussi essayé VirtualBox 4.3.40 : il se lance bien mais c'est quand je lance la machine "Windows NT 3.1 (format VDI) (37.7 Mb)" du forum que j'obtenais un message d'erreur (message que je n'ai pas retenu).

Je précise que l'OS hôte est un Windows 10 64bit.

Merci d'avance :D .

EDIT 1 : Je précise que je veux faire quelques machines virtuelles pour essayer quelques jeux présents sur le forum, donc je ne sais pas si je dois me tourner vers Windows 3.1 ou 3.11. Après je peux utiliser d'autres logiciels de virtualisation mais le seul que j'ai déjà utilisé est VirtualBox.

EDIT 2 : J'ai réinstallé VirtualBox 4.3.40 avec les additions et lorsque je lance la machine Windows 3.1 j'obtiens ce message :
[ img ]
Le fichier .log en question (hébergé sur mon DropBox) :
EDIT 3 : Titre du sujet modifié (rajout de "NT", merci Big Monstro ;) ).

EDIT 4 : Remodification du titre du sujet (ancien titre : "Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit").


----
11 mars 2018, 10 h 19 :

J'ai essayé avec la dernière version de Virtualbox : ça fonctionne :) , même si c'était marqué 4.3 maximum à côté du lien de téléchargement de la VM.

Auteur :  Big Monstro [ 12 mars 2018 02:44 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 sous Windows 10 64bit

Bonsoir Fireboy3000,

A l'évidence, le système invité n'est pas "Windows 3.1" (implicitement le système 16-bit jadis populaire et requérant MS-DOS) mais plutôt "Windows NT 3.1" (beaucoup moins usité mais s'appuyant sur une autre architecture et ancêtre des Windows actuels). La différence doit être mentionnée, notamment dans le titre du sujet, car cela change tout. Le seul point commun entre Windows 3.1 16-bit et NT 3.1 étant l'interface graphique :P. La compatibilité de Windows NT 3.1 avec les jeux DOS est assez mauvaise, alors que le système 16-bit repose justement sur MS-DOS. Pour jouer correctement aux jeux de l'époque, mieux vaut oublier la virtualisation de système NT. Les meilleurs résultats seront obtenus via l'émulation de DOS, grâce à DOSBox.

Merci toutefois d'avoir mentionné que la dernière version de VirtualBox est (désormais ?) capable de faire tourner les VMs de Windows NT 3.1.

Auteur :  Fireboy3000 [ 13 mars 2018 17:26 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

J'ai essayé d'installer "Civilization II" sur DOSBox mais il faut apparemment installer Windows 3.1 avant (jusque là tout va bien :) ) ...
J'ai réussi à débuter l'installation de Windows 3.1 mais il faut changer de disquette pendant l'installation et c'est là que ça se complique :
Comment est-ce que je change de disquette sans quitter l'installation?

Auteur :  Deksor [ 13 mars 2018 18:29 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Windows n'a pas besoin nécessairement de s'installer depuis des disquettes. Tu peux très bien sortir tous les fichiers de toutes les disquettes pour tous les mettre dans un seul répertoire et installer depuis ce répertoire. S'il demande une disquette, tu auras juste à lui dire où se trouvent les fichiers et il saura s'y retrouver

Auteur :  Fireboy3000 [ 13 mars 2018 19:05 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

J'ai essayé de sortir les fichiers avec plusieurs logiciels mais je n'ai pas réussi et en plus je suis tombé sur des logiciels n'inspirant pas confiance :disapprove: ... j'ai cherché Floppy Image mais le site à l'air d'être à vendre selon ce que j'ai vu (je peux le télécharger à partir de clubic ou 01net mais je ne fais pas non plus confiance à ces sites :mh: ).

Tu en as un à me proposer?

Auteur :  Deksor [ 13 mars 2018 19:31 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

7zip sais le faire :lol:


Ou bien winimage (mais c'est plus casse-pied car il faut les ouvrir une à une)

Auteur :  Fireboy3000 [ 13 mars 2018 19:38 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Merci, Il fait vraiment tout 7zip :lol: ...
J'essaie ça dès que je peux et je vous tiens au courant ;) .


----
14 mars 2018, 17 h 03 :

Windows est bien installé mais ne fonctionne pas pour ce que je veux faire :oops: .
J'ai réussi à installer Civilization II mais, lorsque je lance le jeu, il me dit qu'il manque "MSVIDEO.dll" et "AVIFILE.dll".
Il me dit aussi :
"Impossible de trouver le fichier c:\mps\civ2\civ2.exe (ou un des ses composants).
Assurez-vous que le chemin d'accès et le nom sont corrects et que toutes les bibliothèques nécessaires sont disponibles."...
Je constate quand même que l'émulation est beaucoup plus fluide que sous VirtualBox!
J'ai aussi supprimé le programme "Writer" en faisant une mauvaise manipulation.

C'est un peu le bazar :P .

Auteur :  KeetKhat [ 14 mars 2018 17:12 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Il te faut installer Microsoft Video

EDIT : Normalement, il doit être sur le CD de Civilization

Auteur :  Fireboy3000 [ 14 mars 2018 18:25 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Oui en effet, j'ai trouvé un autre setup sur le cd et il s'est avéré que c'est bien celui de Microsoft video :approve: .
Après cela, il me manquait Wing.dll (il me semble) et j'ai donc lancé le setup "wingset.exe" qui était aussi sur le cd dans le répertoire "wing".
Le jeu fonctionne maintenant :approve: mais les couleurs sont "bizarres" (pareilles que dans ma machine sur VirtualBox mais là c'est beaucoup plus fluide :D ).
Est-ce qu'il y a des pilotes à installer pour avoir 256 couleurs ou un "truc" comme ça? :shh:

EDIT : Je précise aussi que je n'ai pas de son, mais ça c'est du luxe :lol: .

Auteur :  Deksor [ 14 mars 2018 18:51 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Oui, pour le son ET la vidéo il te faut des pilotes. De mémoire DOSBox émule une carte vidéo de la marque S3 (je ne sais plus exactement laquelle) et une carte son de type sound blaster. Vas voir dans la section pilote pour trouver ce qu'il te faut ^^

Auteur :  Fireboy3000 [ 14 mars 2018 22:21 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

J'ai trouvé les pilotes normalement :
viewtopic.php?f=8&t=289
viewtopic.php?f=8&t=23&hilit=sound+blaster

Il faut que j'installe les pilotes sous DOS ou sous Windows 3.11?

Auteur :  Big Monstro [ 14 mars 2018 22:34 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

J'ai perdu le fil de la discussion... on parle toujours de Windows NT 3.1, c'est ça ? Qu'est-ce que DOSBox vient faire là ? :P

Plus sérieusement, je crains qu'il faille renommer (encore une fois :mrred:) le titre du sujet, car cela ne correspond plus du tout à la discussion. Il faut bien se dire que les pages de discussions peuvent être lues plusieurs années plus tard (c'est là que réside l'une des différences fondamentales entre le forum et le chat), on doit pouvoir s'y retrouver et savoir quel est le problème que l'on cherche à résoudre dès la lecture du titre.

En gros, l'auteur cherche à jouer à Civilization II via un PC virtuel. Le titre du sujet devrait correspondre à son problème.

Auteur :  Fireboy3000 [ 14 mars 2018 22:56 ]
Sujet du message :  Re: Problème machine virtuelle Windows 3.1 NT sous Windows 10 64bit

Est-ce que "Problème installation et configuration de Windows 3.11 sous DOSBox" serait un bon titre?

EDIT : C'est bon, le titre est modifié!

J'ai aussi installé les pilotes vidéo/image et son :
C'est vraiment beaucoup mieux :approve: !

J'ai utilisé ces deux pilotes :
- Pour l'image : [fr] S3 Trio64 V (Windows 3.1x) (891 Kb) (dans le premier lien de mon précédent message).
- Pour le son : [fr] Sound Blaster Pro (12-8-1993) (2.0 Mb) (dans le deuxième lien de mon précédent message et, puisque il y avait deux disquettes, j'ai aussi extrait les fichiers pour l'installation).

Il faut juste que je retrouve l'application "Writer" et ce sera fini :oops: .


----
16 mars 2018, 19 h 30 :

J'ai retrouvé l'application "Write" dans le répertoire "Windows" mais j'aimerais bien refaire un raccourci dans le fichier "Accessoires" du bureau.
Comment est-ce qu'on fait :roll: ?

Auteur :  michel [ 16 mars 2018 19:47 ]
Sujet du message :  Re: Problème installation et configuration de Windows 3.11 sous DOSBox

Tu ouvres le groupe "Accessoires" c'est pas un fichier mais un "groupe" parce qu'il contient plusieurs fichiers. Ensuite tu ouvres le menu "Fichier". Tu fais "Nouveau" puis "Parcourir" et tu recherches dans c:\windows le fichier "write.exe" puis "ok".

Auteur :  Fireboy3000 [ 16 mars 2018 21:16 ]
Sujet du message :  Re: Problème installation et configuration de Windows 3.11 sous DOSBox

Ah oui, merci!
Je pense que tout est réglé et que je vais pouvoir profiter pleinement de Windows 3.11 :D (et de Dos)!

Encore merci à toutes les personnes qui m'ont aidé, vous êtes super :approve: .

Page 1 sur 1 Fuseau horaire sur UTC+02:00
Powered by phpBB® Forum Software © phpBB Limited
https://www.phpbb.com/