Win3x.Org

Windows & DOS Community

Diverse Windows 3.1 files

Répondre   Page 5 sur 5  [ 49 messages ]
Aller sur la page « 1 2 3 4 5
Auteur Message
OMORES
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 14 juin 2020 12:11
Membre inscrit
Hors-ligne
 
Messages : 8
Inscription : 12 juin 2020 15:01
 
Watlers: It s a Creative Labs model ES1371, (c)1998. No CTxxxx number - the take over was still fresh. (`In January 1998, ENSONIQ Corp. was acquired by Creative Technology Ltd. for $77 million`) After some fiddling, now it has IRQ10, and it stays the same after several restarts. The lags still won t go away. :)
[ img ]

Remax17: Thank you! Now that I have the files copied to Windows\system I did some obvious edits in system.ini
[Enh386]
device=EAPCI.386
[Drivers]
wave=EAPCI31.DRV
It looks like emm386 is mandatory.

With emm386 [on] - because the card is not detected Windows will fail to load.

With emm386 [off] - Windows will load just fine, I think won t even try to detect the card.

[ img ]

[ img ]


Haut
Profil Citer
watlers_world
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 14 juin 2020 18:03
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 50
Inscription : 08 déc. 2008 02:05
 
OMORES, I can not answer questions about drivers that I did not write.
Although I've tested many cards, I've never found a card that worked with those drivers.
I was told that they are not licensed for my creative models.

After testing my 137x driver, it seems quite strange to see it working so well.
On the 900mhz machine, I could not find the problems you describe.
I wish I could remember how I fixed all that. :uh:

Perhaps the old archive was corrupt.
I uploaded the file again at this address:
http://turkeys4me.byethost4.com/programs/index.htm

OMORES, your config.sys and autoexec.bat might also be of interest.

Big Monstro, does your card have the the same errors with version VX?


Haut
Profil Citer
OMORES
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 15 juin 2020 13:35
Membre inscrit
Hors-ligne
 
Messages : 8
Inscription : 12 juin 2020 15:01
 
I will download it again and do some more testing, maybe my Windows 3.11 is not in the best shape. Anyways, I m really happy to have sound in Windows 3.11 thanks to your driver.

Yesterday, I did try your usbwav.dll. I have an external USB - SPDIF interface and a receiver. Windows 10 is on „optical in” - and Windows 3.x is connected to „analog in”. I might use Windows 3.11 on optical as well :approve: if I get the USB driver to work.

In DOS my external USB - SPDIF interface it s initialized (i see a green light turning on once USNDTSR.EXE is loaded) but USBUHCI.COM - will slow the system in such a way that I can see the hourglass drawn line by line on my screen. If i unload it with USBUHCI.COM -u Windows will load be fine, but of course I can t use the driver anymore.

I know is has nothing to do with your driver, maybe you have some newer USB DOS drivers.

Dernière modification par OMORES le 15 juin 2020 13:35, modifié 1 fois.

Haut
Profil Citer
watlers_world
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 15 juin 2020 19:29
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 50
Inscription : 08 déc. 2008 02:05
 
On one computer (a P4 with SB128) I had to set Plug&Play to OFF so that the system BIOS would configure all PCI devices.

Now, on this P4 machine, I can see a potential problem you might have.
On the p4 machine I installed many audio codecs.
Some of the codecs don't seem to work well with the driver.
Are you only having trouble with certain compressed wave files and audio codecs?

I tested an AMD M5A78L-M/USB3 with a third SB128 and the USB mouse did not seem to cause breaks in the audio.
Since I don't have a PCI Voodoo video card and I don't have your particular Network setup, all I can do is guess.
On these machines, MP3 and MOD files are working just fine.
Do MP3 files still skip when you disable your network drivers? (win/N)


The DOS USB drivers require an intel compatible UHCI controller.
For the exact details of how the DOS USB drivers work, you might want to see the authors web site.
http://bretjohnson.us/

Were you testing 123USB05 or USBAUD2?
The 123USB05 driver is the latest version.



Are you trying to use more than card at once or more than one of my drivers at once :?:
Although USB123 should work in parallel with others, the HDA and 137x drivers might not.

----
Posted: 16th June 2020

I've found that the AMD FX motherboard has some issues with my USB keyboard and mouse.
At first everything works well, however, after a while both the mouse and keyboard start acting goofy.
It looks as though USB devices are not being handled properly by the BIOS.

Does this problem sound similar to yours?

----
Posted: 20th June 2020

I tested MP3 files on my 550mhz Pentium III using Windows 3.11 and yet another ENS1373.
It would seem that music playback was uninterrupted.
My Pentium II 350mhz with 137x also plays just fine.

I tested crea1371.dll and Winplay3 on a 133mhz Pentium MMX.
Even at 133mhz, MP3 files seem to play without skipping.

Big Monstro, when do the problems in mp3 playback occur?


Haut
Profil Citer
Big Monstro
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 21 juin 2020 16:03
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3506
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 3.11
 
watlers_world a écrit : *  20 juin 2020 22:59
I tested MP3 files on my 550mhz Pentium III using Windows 3.11 and yet another ENS1373. It would seem that music playback was uninterrupted (...) Big Monstro, when do the problems in mp3 playback occur?
I've removed the Sound Blaster PCI128 from my retro computer, so I can't test it right now. As you tested it with various computers and my Pentium III processor seems to be exactly the same (clocked at 550 MHz), I can assume it would work nice with your newer driver.


Haut
Profil Citer
watlers_world
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 21 juin 2020 18:15
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 50
Inscription : 08 déc. 2008 02:05
 
Big Monstro, I've not updated or changed anything in years.
I just uploaded the same version again with a new number. :roll:


Haut
Profil Citer
Big Monstro
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 21 juin 2020 18:28
Administrateur
Avatar de l’utilisateur
Hors-ligne
 
Messages : 3506
Inscription : 27 juin 2003 15:15
PC Rétro : 80486 DX2/66, MS-DOS & Windows 3.11
 
I've tested an earlier revision on 26th June 2015 (almost five years ago) and you updated the sound driver afterwards (with the addition of a TSR, whose the xms.pas file was updated as late as 2019). I remembered I've used Winplay3 and the clicking noise occured almost permanently.
Big Monstro a écrit : *  26 juin 2015 11:35
there is a significant flaw: although it's OK for Windows sounds, we can hear "clicking noise" while playing sounds on Winplay3.

watlers_world confirmed me it's a driver-related problem. Since the latter still works, he has eventually uploaded it on the Vorro's FTP

  http://nwserveur.no-ip.org/upload/dev/d ... stdrvh.zip


Haut
Profil Citer
watlers_world
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 21 juin 2020 18:47
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 50
Inscription : 08 déc. 2008 02:05
 
It is possible to create a situation that can cause poor audio playback.
And, I'm not the only one who can write poor quality drivers. ;)

We need not worry of a card you don't use anymore.
Big Monstro, thank you for testing my drivers. :wave:


OMORES, do the same problems occur when using Windows 3.1?


Haut
Profil Citer
watlers_world
Sujet du message : Re: Diverse Windows 3.1 files
Publié : 14 juil. 2020 01:33
Membre inscrit
Avatar de l’utilisateur
Hors-ligne
 
Messages : 50
Inscription : 08 déc. 2008 02:05
 
At the moment I'm using an 137x on a NVIDIA chipset with 939 athlon on the Internet.

I'm using WFWG 3.11 and Crea1371.dll version V.W.
MP3 files are playing with no problems.

OMORES, please let me know how you created the problems that you describe.
Do they only occur with that particular video card or network device?


Haut
Profil
Afficher : Trier par : Ordre :
Répondre   Page 5 sur 5  [ 49 messages ]
Revenir à « Retrocomputing » | Aller sur la page « 1 2 3 4 5
Aller :
cron