Win3x.Org

Windows & DOS Community

[Résolu] Problème avec ma carte son ALS 100 (Windows 3.11)

Post Reply   Page 1 of 1  [ 8 posts ]
Author Message
Nintendonut
Post subject: [Résolu] Problème avec ma carte son ALS 100 (Windows 3.11)
Posted: 10 Nov 2011 22:47
Membre inscrit
Offline
 
Posts: 4
Joined: 04 Dec 2010 21:13
 
Bonjour !!

J'ai installé les pilotes pour ma carte de son ALS 100.

Maintenant lorsque je démarre windows, j'entends un DING qui se répète constamment ! DING,DING,DING,DING,DING,DING,DING, !!!

Quand je vais dans l'option sons et que je teste un autre son, lui aussi se met a se répéter sans arrêt !

Pouvez vous m'aider a régler cela ? :shock:

Merci !!

Pentium III 450MHz
256MB RAM


Top
Profile Quote
attilavv
Post subject: Re: Problème son Windows 3.11
Posted: 10 Nov 2011 23:30
Membre inscrit
Offline
 
Posts: 536
Joined: 26 Dec 2008 13:22
 
Elle est PNP ?

Si oui, il doit falloir la configurer sous DOS comme les SB PNP.
Il doit avoir un petit programme pour "lancer" le mode d'émulation car j'ai des doutes que tu as les drivers 100% Windows 3.11 pour ce type de carte.

Cela peux aussi venir de l'IRQ, du DMA, voir de l'adresse ( rare ) qui est partagé alors que Windows 3.11 ( 95, voir 98 ) ne supporte par le partage d'IRQ. C'est qu'une question d'écriture du driver, lors de l'arrivé d'une IRQ, le Windows ne cherche pas à identifier la source MAIS donne la main direct au "premier" pilote.

Ensuite, le son tourne en boucle grâce au DMA ...


Sur une machine moderne ( PIII ) il faut déjà faire la "map" des ressources à la main.
Couper l'option du PNP dans le BIOS et mettre gérer par l'OS. Et là, l'OS, c'est TOI !
Souvent avec les 486/PI je commençais par déactiver les ports séries et le port //.
Cela peux aider, tout comme de déactiver le second IDE.


Attention, tout cela n'est pas une certitude, seulement une direction de RECHERCHE du problème.

_________________

-----------------------------------------
Alienware M18x i7 3840 / CF 7970 / 32Gb 1866Mhz / SSD 256 + Raid 512Gox2
Serveur Minecraft : ASUS portable W90VP T9400 3Ghz CF 4870.


Top
Profile Quote
Nintendonut
Post subject: Re: Problème son Windows 3.11
Posted: 11 Nov 2011 00:13
Membre inscrit
Offline
 
Posts: 4
Joined: 04 Dec 2010 21:13
 
Bonjour !

Pour ce qui est des drivers j'ai pris ceux sur le site ici. La carte est PNP

La carte est sur un port ISA.

Et quest ce que sont une IRQ et une DMA ?

Merci de votre réponse :)


Top
Profile Quote
michel
Post subject: Re: Problème son Windows 3.11
Posted: 11 Nov 2011 00:39
Administrateur
User avatar
Offline
 
Posts: 3326
Joined: 07 Feb 2003 19:46
Retro PC: IBM - PS2 Modèle 85 (carte mère en panne)
 
Bon, j'ai la même sur celui qui tourne sous Windows 3.11 et sur celui qui tourne sous Win 98SE.

Sous DOS, tu vas dans le répertoire où est installée la carte son
quand tu es sur C:\> tu tapes :
cd a3sound puis Entrée
a3config puis Entrée

Dans l'utilitaire sur la gauche tu dois avoir les paramètres suivants :
Port = 220
IRQ = 5
DMA 1 = 1
DMA 2 = 0
Si tu as modifié ces paramètres tu dois redémarrer l'ordi pour que la modif soit prise en compte.
Tu essaie les sons (8 et 16 bits), sur la partie droite.

Pour les autres paramètres MIDI, au milieu tu ne touche pas.

Sinon pour la mémoire, 256 Mos ça fait peut-être un peu beaucoup vu que MS-DOS/Windows 3.x n'en reconnait que 64.

_________________

clikicitoraleur


Top
Profile Quote
Nintendonut
Post subject: Re: Problème son Windows 3.11
Posted: 11 Nov 2011 01:09
Membre inscrit
Offline
 
Posts: 4
Joined: 04 Dec 2010 21:13
 
Merci pour votre réponse !!

Lorsque j'essaie les sons 8 et 16 bit sur le coté j'ai le message d'erreur suivant:

Error: MPU401 IRQ channel is not available

Merci !!


Top
Profile Quote
Der Siebte Schatten
Post subject: Re: Problème son Windows 3.11
Posted: 11 Nov 2011 10:11
Membre d'honneur
User avatar
Offline
 
Posts: 2337
Joined: 09 Feb 2010 21:10
Retro PC: Toshiba Satellite 220CS (WFW3.11/95/NT4)
 
Ah là ça voudrait dire que L'IRQ affecté au MPU401 (c'est un instrument MIDI), est déjà utilisé ! Là à mon avis dans ces paramètres, tu dois pouvoir aussi changer l'IRQ du MPU401 (ça doit être marqué quelque part, sinon petite capture d'écran ou photo :wink: ), essaie de trouver une valeur convenable et dans le PIRE des cas, désactive-le.

_________________

[ img ]
Dunkle Träume, Roter Mond... In den Bäumen lauert ein Phantom...


Top
Profile Quote
michel
Post subject: Re: Problème son Windows 3.11
Posted: 12 Nov 2011 12:22
Administrateur
User avatar
Offline
 
Posts: 3326
Joined: 07 Feb 2003 19:46
Retro PC: IBM - PS2 Modèle 85 (carte mère en panne)
 
Essaie d'enlever un peu de mémoire si c'est de la EDO.
Si tu as installé Windows 3.11 for Worksgroup, met à jour le driver de la souris (serial.386)

:arrow: viewtopic.php?t=13690

Fichier à décompresser.
Sous DOS, tape :
cd windows\system puis Entrée
ren serial.386 serial.old puis entrée
Copie le nouveau serial.386 dans c:\windows\system\

Il y a déja eu quelques soucis de son et/ou de clavier avec ce pilote non mis à jour.

Pour le MPU-401 c'est un autre problème qui n'a rien à voir avec les sons à répétition.

Voir le fichier "readme.txt" de la carte son (dans c:\a3sound).

Lire la partie concernant l'installation du MPU-401 pour Windows 3.1x.

A tout hasard, change ta carte de slot, ça peut résoudre le problème aussi.

_________________

clikicitoraleur


Top
Profile Quote
Nintendonut
Post subject: Re: Problème son Windows 3.11
Posted: 14 Nov 2011 22:24
Membre inscrit
Offline
 
Posts: 4
Joined: 04 Dec 2010 21:13
 
MAGIE !!!

problème réglé !!

Merci ! :)


Top
Profile
Display: Sort by: Direction:
Post Reply   Page 1 of 1  [ 8 posts ]
Return to “Questions et problèmes résolus”
Jump to: