Win3x.Org

Windows & DOS Community

Erreur interne 192 MS Virtual PC 2007 sp1

Post Reply   Page 1 of 1  [ 5 posts ]
Author Message
Viking
Post subject: Erreur interne 192 MS Virtual PC 2007 sp1
Posted: 09 Mar 2017 17:40
Membre inscrit
User avatar
Offline
 
Posts: 237
Joined: 08 Aug 2010 18:14
 
Bonjour. Aujourd'hui, après avoir installé Firefox 52.0 sur mon Windows 7 64 bits hôte, j'ai voulu mettre à jour Firefox sur mon Windows XP virtuel dans MS Virtual PC 2007 sp1.

Mais je n'ai pas pu lancer Windows XP, j'ai eu un message d'erreur interne 192 avec un bouton "réinitialiser". Et en cliquant dessus, plantage total de mon PC, écran figé, pointeur de souris immobile, clavier inerte !
Ctrl+Alt+Suppr ne fonctionnant pas non plus, j'ai fait un reset du PC hôte. Une seconde tentative avec l'XP virtuel ayant donné le même résultat, j'ai "démonté" la machine virtuelle et j'ai voulu voir si je pouvais lancer Windows 2000, résultat identique, même en désactivant la virtualisation assistée.
Idem avec Windows 98.
Je me suis ensuite aperçu que wmm.sys avait disparu du Windows 7 hôte. Je l'ai récupéré sur un autre PC et j'ai tenté une réinstallation à zéro de Virtual PC. J'ai pu dans un premier temps lancer Windows 2000 en désactivant la virtualisation assistée, puis j'ai testé Millennium, ça marchait au début.
J'ai voulu écrire ce message sur ce forum à partir de Millennium mais Virtual PC a de nouveau affiché son message d'erreur interne 192.
Différence cette fois, Windows 7 hôte n'était pas bloqué. J'ai éteint la machine virtuelle pour réécrire ce message.

Mais ce n'est pas fini. J'ai voulu vérifier les paramètres de Virtual PC 2007 entre deux mots de ce message et paf, écran bleu : erreur 0x00000124 !

Je ne comprends pas. Est-ce que la présence du nouveau Firefox 52.0 rendrait inutilisable Virtual PC 2007 ? Ça ne me parait pas logique mais je n'avais jamais eu ces problèmes avant.

_________________

:)


Top
Profile Quote
Big Monstro
Post subject: Re: Erreur interne 192 MS Virtual PC 2007 sp1
Posted: 09 Mar 2017 19:46
Administrateur
User avatar
Offline
 
Posts: 3842
Joined: 27 Jun 2003 15:15
Retro PC: 80486 DX2/66, MS-DOS & Windows 3.11
 
Quelques liens externes:

  • http://sonable.org/virtual-pc-internal-error-192.html
  • http://www.vistax64.com/virtual-pc/190069-re-internal-virtual-machine-error-192-has-occurred.html
  • http://groups.google.com/forum/#!topic/microsoft.public.virtualpc/2SoCxKwUee8

Non testés mais j'espère que ces liens t'aideront !


Top
Profile Quote
Viking
Post subject: Re: Erreur interne 192 MS Virtual PC 2007 sp1
Posted: 10 Mar 2017 10:39
Membre inscrit
User avatar
Offline
 
Posts: 237
Joined: 08 Aug 2010 18:14
 
Bonjour Big Monstro. J'ai préféré ne pas essayer ReimageRepaire du lien sonable.org. J'ai fait une recherche Google et ce logiciel a mauvaise réputation, considéré comme un malware publicitaire.
Je n'ai pas pu essayer d'autre méthode car mon PC hôte est complètement planté dès que j'essaie de lancer une machine virtuelle.

J'ai donc renoncé, j'ai supprimé toutes mes machines virtuelles et désinstallé MS Virtual PC 2007 sp1.

_________________

:)


Top
Profile Quote
Big Monstro
Post subject: Re: Erreur interne 192 MS Virtual PC 2007 sp1
Posted: 10 Mar 2017 12:47
Administrateur
User avatar
Offline
 
Posts: 3842
Joined: 27 Jun 2003 15:15
Retro PC: 80486 DX2/66, MS-DOS & Windows 3.11
 
Voilà qui est fort regrettable...

Si ton PC hôte le permet, une alternative serait
d'utiliser Virtual PC à l'intérieur d'un autre hyperviseur :

[ img ]

Cela peut être utile, Virtual PC a quelques atouts par rapport aux autres !


Top
Profile Quote
Viking
Post subject: Re: Erreur interne 192 MS Virtual PC 2007 sp1
Posted: 11 Mar 2017 11:59
Membre inscrit
User avatar
Offline
 
Posts: 237
Joined: 08 Aug 2010 18:14
 
Bon, j'ai encore essayé une ré-installation de MS Virtual PC 2007 sp1 sur mon PC hôte Windows 7, après avoir effacé toute trace du précédent.
J'ai eu une mise à jour de sécurité pour mon PC hôte (la KB969856).
Et puis j'ai ré-installé une sauvegarde de machine virtuelle Windows 2000 modifié avec kernelx qui était encore doté de Firefox 43.

J'ai lancé la machine et re-belote, erreur interne 192.

J'ai éteint la machine virtuelle, dans les paramètres j'ai désactivé la virtualisation assistée par matériel. La machine a démarré mais j'ai eu un message du pare-feu du PC hôte me demandant d'autoriser Virtual PC sur le réseau. Evidemment j'ai autorisé.

Mais impossible de lancer Firefox 43. Une page s'ouvre très vite et se referme instantanément. Par contre, Internet Explorer 6.0 fonctionne.

Et il ne faut surtout pas que j'essaie de me connecter à internet avec mon PC hôte en même temps que la machine virtuelle est en marche car j'ai un plantage total du PC hôte.

Il y a dû y avoir une mise à jour récente de Windows 7 qui rend impossible le fonctionnement normal de Virtual PC 2007.

Je me demande si le problème apparaitrait avec Virtual PC 2004, il faudra que j'essaie.

Edit : Virtual PC 2004 ne s'installant pas sur un Windows 7 64 bits, j'ai ré-installé Virtual PC 2007 sp1 sur mon second disque dur avec Windows 8.1 et ça marche, j'ai utilisé une sauvegarde d'un Windows 2000 virtuel. Le problème semblerait donc ne concerner que Windows 7. Je ne sais pas s'il peut survenir aussi sur un W7 32 bits.
Si d'autres rencontrent ce problème, précisez-le.

_________________

:)


Top
Profile
Display: Sort by: Direction:
Post Reply   Page 1 of 1  [ 5 posts ]
Return to “Emulation et virtualisation”
Jump to: