Win3x.Org

Windows & DOS Community

Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)

Post Reply   Page 1 of 1  [ 7 posts ]
Author Message
Albert_3
Post subject: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 03:23
Membre inscrit
Offline
 
Posts: 3
Joined: 31 Jul 2012 01:53
 
Bonjour tout le monde,

J'ai installé Windows 98se sur mon PC virtuel créé avec Virtual box et jusqu'ici, je ne m'en sortais pas trop mal mais par contre, je n'arrive pas à avoir le son.

J'ai essayé d'installer les drivers SB16 trouvés sur ce site et ça n'a rien donné.

Idem avec des drivers AC'97 .
Dans le gestionnaire de périphérique, il ne me détectait aucune carte son avant que je n'installe les drivers AC'97 (via un .exe, donc très simple) mais même maintenant , ça ne marche toujours pas :(

Quand j'essaie de lire un fichier audio, j'ai un message d'erreur "Impossible de lire le flux audio : aucun matériel audio n'est disponible ou bien le matériel audio ne répond pas"

Autant, ça a été simple pour la carte graphique autant je galère pour le son.

Quelqu'un pourrait il m'éclairer svp?


Top
Profile Quote
Der Siebte Schatten
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 09:53
Membre d'honneur
User avatar
Offline
 
Posts: 2337
Joined: 09 Feb 2010 21:10
Retro PC: Toshiba Satellite 220CS (WFW3.11/95/NT4)
 
Salutations Albert_3 !

Alors, je n'utilise pas VirtualBox, mais n'y a-t-il pas de compléments d'ordinateurs virtuels pour Windows 98 sur VirtualBox ? Cela aurait été d'emblée le plus simple...
Sinon j'ai cru comprendre que c'est effectivement une carte audio AC'97 par défaut sur VirtualBox. Mais si tu n'arrives pas à la configurer, tu peux apparemment changer dans les paramètres de la machine virtuelle pour une Sound Blaster 16 qui aura plus de chances de fonctionner...

Sinon, quelqu'un qui utilise VirtualBox ?

_________________

[ img ]
Dunkle Träume, Roter Mond... In den Bäumen lauert ein Phantom...


Top
Profile Quote
DoomQuakeKeen
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 17:33
Membre inscrit
User avatar
Offline
 
Posts: 2568
Joined: 05 Apr 2012 17:38
Retro PC: Amstrad PC2086/30, 8086, 640K, VGA, 32Mo RLL
 
Salut,

En effet il n'existe pas à ma connaissance (mais je peux me tromper) de compléments d'ordinateurs virtuels pour 98 comme sur VMWare (non ?).

Il te faut aller dans les propriétés de la machine virtuelle (clic droit puis configuration) et dans la partie "Son" mettre l'option "Contrôleur audio" en "SoundBlaster 16".

Tu n'auras ensuite plus qu'à installer les pilotes pour la SoundBlaster 16 et tu devrais être capable d'avoir du son.

Il doit bien exister des pilotes compatibles avec les AC97 de VirtualBox puisque c'est la carte sélectionnée par défaut mais y passer en SB16 sera plus rapide.

_________________

Vérification de l’orthographe pour Mozilla Firefox : http://addons.mozilla.org/fr/firefox/a ... alecte-fr/
Vérification de l’orthographe pour Google Chrome : http://chrome.google.com/webstore/sear ... ecte?hl=fr
modérateur : [b][color=#00AA00][/color][/b]
administrateur : [b][color=#AA0000][/color][/b]
membre : [b][color=#006699][/color][/b]
[ img ]


Top
Profile Quote
remax17
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 21:44
Membre inscrit
User avatar
Offline
 
Posts: 1233
Joined: 22 Sep 2010 15:03
Retro PC: PIII 500mhz -384Mb RAM - Voodoo 2 en SLI
 
J'ai installé tous les Windows 9x sous Virtualbox et ce un bon paquet de fois, j'ai toujours eu le son direct en gardant les paramètres par défaut... :o_O:


Top
Profile Quote
Albert_3
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 22:22
Membre inscrit
Offline
 
Posts: 3
Joined: 31 Jul 2012 01:53
 
Bizarre, donc.

J'ai bien essayé routes les combinaisons dans les paramètres son de VirtualBox (Pilote audio factice + intel audio HD, puis ICH AC97, puis Soundblaster16 et ensuite Direct sound + intel audio HD, puis ICH AC97, puis Soundblaster16)
Rien à faire, je n'ai même pas l’icône de haut parleur en bas à droite dans la barre des tâches.

A la rigueur, je pourrais essayer de re-créer une machine virtuelle et tout ré-installer.


Top
Profile Quote
tortipouss
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 26 Sep 2017 22:33
Membre d'honneur
User avatar
Offline
 
Posts: 635
Joined: 09 Mar 2006 21:29
Retro PC: Amstrad 9486i http://tortiplouf.be/appareils.html
 
Tutorial: Windows 95/98 guest OSes: http://forums.virtualbox.org/viewtopic.php?t=9918
Tu as essayé avec le driver “Soundblaster 16 or AWE 32 or compatible”?

[ img ]


Top
Profile Quote
Albert_3
Post subject: Re: Je ne réussis pas à avoir le son sous Windows 98 (Virtualbox)
Posted: 28 Sep 2017 01:04
Membre inscrit
Offline
 
Posts: 3
Joined: 31 Jul 2012 01:53
 
J'ai tout effacé (format c: comme au bon vieux temps :P), ré-installé et le son refonctionne.

J'ai dû commettre une erreur à un moment donné.

Bref, problème résolu et merci pour votre aide ;)


Top
Profile
Display: Sort by: Direction:
Post Reply   Page 1 of 1  [ 7 posts ]
Return to “Emulation et virtualisation”
Jump to: