Win3x.Org

Windows & DOS Community

[Résolu] Windows 7 ne démarre plus !

Post Reply   Page 1 of 6  [ 55 posts ]
Jump to page 1 2 3 4 5 6 »
Author Message
zmbl
Post subject: [Résolu] Windows 7 ne démarre plus !
Posted: 09 Mar 2009 16:27
Membre d'honneur
User avatar
Offline
 
Posts: 271
Joined: 14 Feb 2008 13:59
 
Hello

Je me retrouve confronté à un très gros et très emm**dant problème.

En multiboot XP/Seven sur mon PC, je décide de réinstaller XP (instable, BSoDs, bugs, lenteurs, etc). Je prends mon CD de réinstall Acer, je boote dessus, et hop, ça réinstalle.

Mais bien sûr, problème, vous l'avez sûrement déjà deviné. L'install de XP m'a supprimé la configuration multi boot, et je ne peux plus booter que sur XP.

Bon, ça m'embète un peu quoi. J'aimerais bien pouvoir retourner sur Seven.

J'ai cherché sur Google bien sûr. Et je suis tombé sur l'excellent article de Microsoft à ce sujet : ici. Fou de joie (tout va revenir à la normale ! :D), je lance les quelques commandes indiquées dans la partie "Résolution".

et Bang, ça marche pas. Une erreur "Updated NTFS filesystem bootcode. The update may be unreliable since the volume could not be locked during the update: Access is denied" à chaque fois. :(

Qu'ai-je fait de mal ? Vous sauriez m'aider ?

Merci d'avance.

_________________

« Non, Tournesol. Tryphon Tournesol. »


Top
Profile Quote
Ycor
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 18:30
 
 
J'ai dans l'idée que cette manip ne peut pas se faire à partir de XP, mais seulement en ligne de commande (=> volume non monté). Peut-être à partir du DVD de Seven ? J'aurai ien essayé, mais plus moyen de mettre la main sur mon DVD :evil:


Top
Quote
zmbl
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:10
Membre d'honneur
User avatar
Offline
 
Posts: 271
Joined: 14 Feb 2008 13:59
 
Merci de ta réponse.

J'ai déjà essayé :
- depuis XP
- depuis XP en compte "Administrateur"
- depuis XP en mode sans échec
- depuis le CD de Seven, en mode récup
- idem, avec /FORCE dans la ligne de commande (dans ce cas, plus de messages d'erreur "Access denied", mais ça marche toujours pas)
- avec Vistabootpro ("The specified file is not found")

Là je teste ce truc. J'espère que ça va marcher, ça commence à m'échauffer les oreilles ce problème.

_________________

« Non, Tournesol. Tryphon Tournesol. »


Top
Profile Quote
corwintirnanog
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:25
Membre inscrit
User avatar
Offline
 
Posts: 326
Joined: 23 Oct 2005 14:13
 
je dirais que le message d'erreur est explicite et la situation inextricable.
NTFS possède un système de droits d'accès liés à un compte utilisateur et cet utilisateur à disparu => Il est impossible de modifier le système de fichier à partir d'un autre système Windows.

C'est un peu comme pour ces soldats qui avaient des comptes mails et qui sont mort en Iraq, les comptes sont toujours là mais inaccessibles à leurs proches qui n'ont pas les mots de passe.

Eventuellement tu peux prendre un CD Linux et essayer de récupérer des fichiers, mais tu ne récupéreras pas l'installation Windows. Ca marche car l'implémentation Linux-NTFS ne tient pas compte des droits d'accès.

_________________

Dernière visite : 26 août 2009


Top
Profile Quote
zmbl
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:37
Membre d'honneur
User avatar
Offline
 
Posts: 271
Joined: 14 Feb 2008 13:59
 
Bah pourtant je peux accéder à mes fichiers...
Et avec /force l'erreur n'apparait plus.

C'est franchement mal foutu leur truc !

_________________

« Non, Tournesol. Tryphon Tournesol. »


Top
Profile Quote
corwintirnanog
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:43
Membre inscrit
User avatar
Offline
 
Posts: 326
Joined: 23 Oct 2005 14:13
 
@Ycor:
Quand il n'avait que Seven, son Seven a été installé par l'utilisateur ayant le rôle administrateur et comme nom 'A'.
Les droits du système de fichier sont liés à 'A'.

Il installe XP, avec un administrateur nommé 'B'.

'B' n'a aucun droit sur le système de fichier de Seven et les fichiers s'y trouvant car leurs droits sont exclusivement attachés à 'A'.

@Zmbl:
Ce n'est pas mal foutu, c'est au contraire une sécurité qui fonctionne bien. NT n'a pas été inventé pour des ordinateurs perso, mais pour des serveurs (NTFS est une amélioration du système de fichier ayant cours sur VAX)

Je ne connais pas l'effet de l'option "/force".

_________________

Dernière visite : 26 août 2009


Top
Profile Quote
chocoboss
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:46
Membre inscrit
User avatar
Offline
 
Posts: 190
Joined: 24 May 2006 16:58
 
Essay d'installé Grub, si tu le configure bien tu t'en sortira peut être


Top
Profile Quote
zmbl
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:50
Membre d'honneur
User avatar
Offline
 
Posts: 271
Joined: 14 Feb 2008 13:59
 
Bizarre, car j'ai bien les droits d'écriture sur le disque Seven, j'arrive bien à tout bidouiller dans \Boot\.

Mon problème maintenant, c'est que j'essaye d'utiliser Bcdedit depuis XP. J'arrive à une erreur "file not found" pour le fichier BCD (que je viens de créer). Il doit surement chercher dans la partition système XP, alors que je veux modifier Seven >_<

_________________

« Non, Tournesol. Tryphon Tournesol. »


Top
Profile Quote
corwintirnanog
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 19:57
Membre inscrit
User avatar
Offline
 
Posts: 326
Joined: 23 Oct 2005 14:13
 
Tu peux toujours faire ce que Microsoft indiquait dans l'article, reformater tout, installer XP puis Seven :mrgreen:

_________________

Dernière visite : 26 août 2009


Top
Profile Quote
zmbl
Post subject: Re: Seven ne démarre plus !
Posted: 09 Mar 2009 20:02
Membre d'honneur
User avatar
Offline
 
Posts: 271
Joined: 14 Feb 2008 13:59
 
Lol, c'est toujours une solution, mais je la réserve pourla fin ^^.

Bon allez, je vais lâcher une blague pour détendre l'atmosphère.
La partition n'était pas active, d'où tous les problèmes. XP a dù "dés-active-r" la partition.

Tout ça pour un truc si simple, ça me plombe !

J'ai marqué la partition comme active depuis XP. J'ai rebooté, et il a bien booté sur ma partition Seven. Il s'est plaint que le fichier de boot était manquant. Normal, avec toutes les bidouilles que j'avais faites dessus...

Là, je viens de lancer une réparation. Il a détecté mon disque, très bon point. Je crois que tout va être enfin résolu :D

Merci à tous ceux qui m'ont aidé, Corwintirnanog, Ycor et Chocoboss. C'est pas encore fini, mais ça vient bon.

Je vous tiens au courant :)

EDIT : C'est tout bon maintenant. Tout est réparé pour le mieux. (par contre, j'ai hérité du vieux bootscreen de vista, horrible, avec la barre défilante verte. beurk)

_________________

« Non, Tournesol. Tryphon Tournesol. »


Top
Profile Quote
Display: Sort by: Direction:
Post Reply   Page 1 of 6  [ 55 posts ]
Return to “Questions et problèmes résolus” | Jump to page 1 2 3 4 5 6 »
Jump to: